CVE-2005-0239
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:43
NMCOS    

[原文]viewcert.php in the S/MIME plugin 0.4 and 0.5 for Squirrelmail allows remote attackers to execute arbitrary commands via shell metacharacters in the cert parameter.


[CNNVD]SquirrelMail S/MIME Plug-in远程命令执行漏洞(CNNVD-200505-605)

        用于Squirrelmail的S/MIME plugin 0.4和0.5中的viewcert.php使得远程攻击者可以通过在cert参数内的shell元字符来执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:squirrelmail:s_mime_plugin:0.5
cpe:/a:squirrelmail:s_mime_plugin:0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0239
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0239
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-605
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/502328
(VENDOR_ADVISORY)  CERT-VN  VU#502328
http://xforce.iss.net/xforce/xfdb/19242
(PATCH)  XF  squirrelmail-smime-command-execution(19242)
http://www.squirrelmail.org/plugin_view.php?id=54
(UNKNOWN)  CONFIRM  http://www.squirrelmail.org/plugin_view.php?id=54
http://www.idefense.com/application/poi/display?id=191&type=vulnerabilities&flashstatus=false
(VENDOR_ADVISORY)  IDEFENSE  20050207 SquirrelMail S/MIME Plugin Command Injection Vulnerability

- 漏洞信息

SquirrelMail S/MIME Plug-in远程命令执行漏洞
高危 输入验证
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        用于Squirrelmail的S/MIME plugin 0.4和0.5中的viewcert.php使得远程攻击者可以通过在cert参数内的shell元字符来执行任意命令。

- 公告与补丁

        暂无数据

- 漏洞信息

13639
SquirrelMail S/MIME Plugin Arbitrary Command Injection
Remote / Network Access
Loss of Integrity Upgrade
Exploit Private Vendor Verified, Coordinated Disclosure

- 漏洞描述

- 时间线

2005-02-06 Unknow
Unknow 2005-02-06

- 解决方案

Upgrade to version 0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SquirrelMail S/MIME Plug-in Remote Command Execution Vulnerability
Input Validation Error 12467
Yes No
2005-02-07 12:00:00 2009-07-12 10:06:00
Discovery is credited to Karol Wiesek.

- 受影响的程序版本

SquirrelMail S/MIME Plugin 0.5
SquirrelMail S/MIME Plugin 0.4
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux 8.1
S.u.S.E. Linux 8.0 i386
S.u.S.E. Linux 8.0
S.u.S.E. Linux 7.3 sparc
S.u.S.E. Linux 7.3 ppc
S.u.S.E. Linux 7.3 i386
S.u.S.E. Linux 7.3
S.u.S.E. Linux 7.2 i386
S.u.S.E. Linux 7.2
S.u.S.E. Linux 7.1 x86
S.u.S.E. Linux 7.1 sparc
S.u.S.E. Linux 7.1 ppc
S.u.S.E. Linux 7.1 alpha
S.u.S.E. Linux 7.1
S.u.S.E. Linux 7.0 sparc
S.u.S.E. Linux 7.0 ppc
S.u.S.E. Linux 7.0 i386
S.u.S.E. Linux 7.0 alpha
S.u.S.E. Linux 7.0
S.u.S.E. Linux 6.4 ppc
S.u.S.E. Linux 6.4 i386
S.u.S.E. Linux 6.4 alpha
S.u.S.E. Linux 6.4
S.u.S.E. Linux 6.3 ppc
S.u.S.E. Linux 6.3 alpha
S.u.S.E. Linux 6.3
S.u.S.E. Linux 6.2
S.u.S.E. Linux 6.1 alpha
S.u.S.E. Linux 6.1
S.u.S.E. Linux 6.0
S.u.S.E. Linux 5.3
S.u.S.E. Linux 5.2
S.u.S.E. Linux 5.1
S.u.S.E. Linux 5.0
S.u.S.E. Linux 4.4.1
S.u.S.E. Linux 4.4
S.u.S.E. Linux 4.3
S.u.S.E. Linux 4.2
S.u.S.E. Linux 4.0
S.u.S.E. Linux 3.0
S.u.S.E. Linux 2.0
S.u.S.E. Linux 1.0
SquirrelMail S/MIME Plugin 0.6

- 不受影响的程序版本

SquirrelMail S/MIME Plugin 0.6

- 漏洞讨论

A vulnerability exists in the SquirrelMail S/MIME plug-in that may allow malicious Web mail users to execute system commands remotely. The source of the problem is that user data is passed to the PHP 'exec()' function without sufficient sanitization.

Command execution would occur in the context of the Web server hosting the vulnerable software.

- 漏洞利用

There is no exploit required.

- 解决方案

This issue has been resolved in version 0.6 of the S/MIME plugin.

SuSE has released advisory SUSE-SA:2005:015 reporting in the pending vulnerabilities section that new Squirrelmail packages are available on their ftp server. Please see the referenced advisory for more information.

SUSE has released an advisory SUSE-SR:2005:008 to address various security issues affecting SUSE products. Please see the referenced advisory for more information.


SquirrelMail S/MIME Plugin 0.4

SquirrelMail S/MIME Plugin 0.5

S.u.S.E. Linux Personal 8.2

S.u.S.E. Linux Personal 9.0

S.u.S.E. Linux Personal 9.0 x86_64

S.u.S.E. Linux Personal 9.1 x86_64

S.u.S.E. Linux Personal 9.1

S.u.S.E. Linux Personal 9.2

S.u.S.E. Linux Personal 9.2 x86_64

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站