CVE-2005-0208
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:08:29
NMCOPS    

[原文]The HTML parsing functions in Gaim before 1.1.4 allow remote attackers to cause a denial of service (application crash) via malformed HTML that causes "an invalid memory access," a different vulnerability than CVE-2005-0473.


[CNNVD]Gaim远程拒绝服务漏洞(CNNVD-200505-406)

        Gaim 1.1.4之前版本中的HTML解析函数,允许远程攻击者通过可引起"无效内存访问"的畸形HTML来触发拒绝服务(应用程序崩溃)攻击。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:rob_flynn:gaim:1.1.1
cpe:/a:rob_flynn:gaim:1.1.0
cpe:/a:rob_flynn:gaim:1.1.2
cpe:/a:rob_flynn:gaim:1.1.3

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10477Integer overflow in parse_comment in GnuPG (gpg) 1.4.4 allows remote attackers to cause a denial of service (segmentation fault) via a craft...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0208
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0208
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-406
(官方数据源) CNNVD

- 其它链接及资源

http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000933
(PATCH)  CONECTIVA  CLA-2005:933
http://gaim.sourceforge.net/security/?id=12
(VENDOR_ADVISORY)  CONFIRM  http://gaim.sourceforge.net/security/?id=12
http://marc.info/?l=bugtraq&m=110935655500670&w=2
(UNKNOWN)  BUGTRAQ  20050225 [USN-85-1] Gaim vulnerabilities
http://www.gentoo.org/security/en/glsa/glsa-200503-03.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200503-03
http://www.kb.cert.org/vuls/id/795812
(VENDOR_ADVISORY)  CERT-VN  VU#795812
http://www.mandriva.com/security/advisories?name=MDKSA-2005:049
(UNKNOWN)  MANDRAKE  MDKSA-2005:049
http://www.novell.com/linux/security/advisories/2005_36_sudo.html
(UNKNOWN)  SUSE  SUSE-SA:2005:036
http://www.redhat.com/support/errata/RHSA-2005-215.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:215
http://www.securityfocus.com/archive/1/archive/1/426078/100/0/threaded
(UNKNOWN)  FEDORA  FLSA:158543
http://www.securityfocus.com/bid/12660
(UNKNOWN)  BID  12660

- 漏洞信息

Gaim远程拒绝服务漏洞
中危 其他
2005-05-02 00:00:00 2005-10-25 00:00:00
远程  
        Gaim 1.1.4之前版本中的HTML解析函数,允许远程攻击者通过可引起"无效内存访问"的畸形HTML来触发拒绝服务(应用程序崩溃)攻击。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://download.fedoralegacy.org/redhat/9/updates/i386/gaim-1.5.0-0.90.1.legacy.i386.rpm

- 漏洞信息 (F36413)

Gentoo Linux Security Advisory 200503-3 (PacketStormID:F36413)
2005-03-03 00:00:00
Gentoo  security.gentoo.org
advisory
linux,gentoo
CVE-2005-0208,CVE-2005-0472,CVE-2005-0473
[点击下载]

Gentoo Linux Security Advisory GLSA 200503-03 - Specially crafted SNAC packets sent by other instant-messaging users can cause Gaim to loop endlessly (CVE-2005-0472). Malformed HTML code could lead to invalid memory accesses (CVE-2005-0208 and CVE-2005-0473). Versions less than 1.1.4 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200503-03
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Gaim: Multiple Denial of Service issues
      Date: March 01, 2005
      Bugs: #83253
        ID: 200503-03

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in Gaim which could allow a
remote attacker to crash the application.

Background
==========

Gaim is a full featured instant messaging client which handles a
variety of instant messaging protocols.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /  Vulnerable  /                          Unaffected
    -------------------------------------------------------------------
  1  net-im/gaim       < 1.1.4                                >= 1.1.4

Description
===========

Specially crafted SNAC packets sent by other instant-messaging users
can cause Gaim to loop endlessly (CAN-2005-0472). Malformed HTML code
could lead to invalid memory accesses (CAN-2005-0208 and
CAN-2005-0473).

Impact
======

Remote attackers could exploit these issues, resulting in a Denial of
Service.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Gaim users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/gaim-1.1.4"

References
==========

  [ 1 ] CAN-2005-0208
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0208
  [ 2 ] CAN-2005-0472
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0472
  [ 3 ] CAN-2005-0473
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0473

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200503-03.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
    

- 漏洞信息

14204
Gaim Malformed HTML Client DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-02-24 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Gaim Remote Denial of Service Vulnerability
Failure to Handle Exceptional Conditions 12660
Yes No
2005-02-25 12:00:00 2006-12-22 12:04:00
This vulnerability was announced by the vendor.

- 受影响的程序版本

S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
Rob Flynn Gaim 1.1.3
+ Red Hat Fedora Core3
+ Red Hat Fedora Core2
Rob Flynn Gaim 1.1.2
+ Red Hat Fedora Core3
+ Red Hat Fedora Core2
Rob Flynn Gaim 1.1.1
Rob Flynn Gaim 1.0.2
+ Gentoo Linux
+ Slackware Linux 10.0
+ Slackware Linux 9.1
+ Slackware Linux 9.0
+ Slackware Linux -current
Rob Flynn Gaim 1.0.1
+ Red Hat Enterprise Linux AS 3
+ RedHat Desktop 3.0
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux WS 3
Rob Flynn Gaim 1.0
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
Rob Flynn Gaim 0.77
Rob Flynn Gaim 0.59.8
+ Gentoo Linux 0.7
+ Gentoo Linux 0.5
+ HP Secure OS software for Linux 1.0
+ RedHat Linux 9.0 i386
+ RedHat Linux 7.3 i386
+ RedHat Linux 7.3
+ RedHat Linux 7.2 ia64
+ RedHat Linux 7.2 i386
+ RedHat Linux 7.2
+ RedHat Linux 7.1 ia64
+ RedHat Linux 7.1 i386
+ RedHat Linux 7.1 alpha
+ RedHat Linux 7.1
+ S.u.S.E. Linux 8.1
+ S.u.S.E. Linux Personal 8.2
+ Sun Linux 5.0
RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
RedHat Linux 7.3 i386
RedHat Linux 7.3
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux ES 4
RedHat Desktop 4.0
Red Hat Fedora Core2
Red Hat Fedora Core1
Red Hat Enterprise Linux AS 4
Peachtree Linux release 1
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Mandriva Linux Mandrake 10.0 AMD64
Mandriva Linux Mandrake 10.0
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
Rob Flynn Gaim 1.1.4
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Conectiva Linux 4.1
+ Gentoo Linux
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64

- 不受影响的程序版本

Rob Flynn Gaim 1.1.4
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Conectiva Linux 4.1
+ Gentoo Linux
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64

- 漏洞讨论

Gaim is affected by a remote denial-of-service vulnerability. This issue can allow remote attackers to crash an affected client.

A vulnerability in the client arises during the parsing of malformed HTML data. This issue is nearly identical to that reported in BID 12589, but is a separate issue.

Gaim versions prior to 1.1.4 are affected by this issue.

- 漏洞利用

An exploit is not required.

- 解决方案

Vendor upgrades are available. Please see the referenced advisories for more information.


Rob Flynn Gaim 0.59.8

Rob Flynn Gaim 0.77

Rob Flynn Gaim 1.0

Rob Flynn Gaim 1.0.1

Rob Flynn Gaim 1.0.2

Rob Flynn Gaim 1.1.1

Rob Flynn Gaim 1.1.2

Rob Flynn Gaim 1.1.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站