CVE-2005-0199
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:35
NMCO    

[原文]Integer underflow in the Lists_MakeMask() function in lists.c in ngIRCd before 0.8.2 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a long MODE line that causes an incorrect length calculation, which leads to a buffer overflow.


[CNNVD]ngIRCd远程缓冲区溢出漏洞(CNNVD-200505-293)

        ngIRCd 0.8.2之前版本的lists.c中包含的Lists_MakeMask()函数存在整数下溢漏洞,远程攻击者可以通过较长的可引起不正确长度计算的MODE行来引发拒绝服务(应用程序崩溃)攻击,以及可能执行任意代码,从而导致缓冲区溢出。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ngircd:ngircd:0.6
cpe:/a:ngircd:ngircd:0.7.6
cpe:/a:ngircd:ngircd:0.7
cpe:/a:ngircd:ngircd:0.7.1
cpe:/a:ngircd:ngircd:0.8
cpe:/a:ngircd:ngircd:0.7.7
cpe:/a:ngircd:ngircd:0.6.1
cpe:/a:ngircd:ngircd:0.7.5
cpe:/a:ngircd:ngircd:0.8.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0199
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0199
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-293
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/19143
(VENDOR_ADVISORY)  XF  ngircd-listmakemask-bo(19143)
http://www.securityfocus.com/bid/12397
(PATCH)  BID  12397
http://www.gentoo.org/security/en/glsa/glsa-200501-40.xml
(PATCH)  GENTOO  GLSA-200501-40
http://arthur.ath.cx/pipermail/ngircd-ml/2005-January/000228.html
(PATCH)  MLIST  [ngIRCd-ML] 20050126 ngIRCd 0.8.2
http://bugs.gentoo.org/show_bug.cgi?id=79705
(VENDOR_ADVISORY)  CONFIRM  http://bugs.gentoo.org/show_bug.cgi?id=79705
http://securitytracker.com/id?1013047
(UNKNOWN)  SECTRACK  1013047
http://secunia.com/advisories/14059
(UNKNOWN)  SECUNIA  14059
http://secunia.com/advisories/14056
(UNKNOWN)  SECUNIA  14056

- 漏洞信息

ngIRCd远程缓冲区溢出漏洞
高危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        ngIRCd 0.8.2之前版本的lists.c中包含的Lists_MakeMask()函数存在整数下溢漏洞,远程攻击者可以通过较长的可引起不正确长度计算的MODE行来引发拒绝服务(应用程序崩溃)攻击,以及可能执行任意代码,从而导致缓冲区溢出。

- 公告与补丁

        暂无数据

- 漏洞信息

13300
ngIRCd Lists_MakeMask() Remote Overflow DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown Vendor Verified

- 漏洞描述

A remote overflow exists in ngIRCd. ngIRCd contains an integer overflow in the Lists_MakeMask() function. With a specially crafted request, an attacker can cause a DoS and arbitrary code execution resulting in a loss of availability and integrity.

- 时间线

2005-01-31 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.8.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站