CVE-2005-0158
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:28
NMCOPS    

[原文]Format string vulnerability in bidwatcher before 1.3.17 allows remote malicious web servers from eBay, or a spoofed eBay server, to cause a denial of service and possibly execute arbitrary code via certain responses.


[CNNVD]Bidwatcher远程格式化字符串漏洞(CNNVD-200505-167)

        bidwatcher 1.3.17之前版本中的格式化字符串漏洞,允许远程eBay的恶意Web服务器或被欺骗的eBay服务器,通过特定的响应来引起拒绝服务攻击并且可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:bidwatcher:bidwatcher:1.3.8
cpe:/a:bidwatcher:bidwatcher:1.3.2
cpe:/a:bidwatcher:bidwatcher:1.3.1
cpe:/a:bidwatcher:bidwatcher:1.1.9.2
cpe:/a:bidwatcher:bidwatcher:1.1.2
cpe:/a:bidwatcher:bidwatcher:1.3.10
cpe:/a:bidwatcher:bidwatcher:1.3.9
cpe:/a:bidwatcher:bidwatcher:1.3.14
cpe:/a:bidwatcher:bidwatcher:1.3.6
cpe:/a:bidwatcher:bidwatcher:1.3.12
cpe:/a:bidwatcher:bidwatcher:1.3.11
cpe:/a:bidwatcher:bidwatcher:1.3.3
cpe:/a:bidwatcher:bidwatcher:1.3.13
cpe:/a:bidwatcher:bidwatcher:1.1.9.1
cpe:/a:bidwatcher:bidwatcher:1.0.5
cpe:/a:bidwatcher:bidwatcher:1.2.0
cpe:/a:bidwatcher:bidwatcher:1.3.4
cpe:/a:bidwatcher:bidwatcher:1.3.0_beta
cpe:/a:bidwatcher:bidwatcher:1.3.16
cpe:/a:bidwatcher:bidwatcher:1.1.7
cpe:/a:bidwatcher:bidwatcher:1.1.8
cpe:/a:bidwatcher:bidwatcher:1.3.15
cpe:/a:bidwatcher:bidwatcher:1.1.9
cpe:/a:bidwatcher:bidwatcher:1.3.7
cpe:/a:bidwatcher:bidwatcher:1.3.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0158
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0158
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-167
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200503-06.xml
(PATCH)  GENTOO  GLSA-200503-06
http://www.debian.org/security/2005/dsa-687
(VENDOR_ADVISORY)  DEBIAN  DSA-687

- 漏洞信息

Bidwatcher远程格式化字符串漏洞
高危 格式化字符串
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        bidwatcher 1.3.17之前版本中的格式化字符串漏洞,允许远程eBay的恶意Web服务器或被欺骗的eBay服务器,通过特定的响应来引起拒绝服务攻击并且可能执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/bidwatcher/bidwatcher-1.3.17.tar.gz

- 漏洞信息 (F36449)

Gentoo Linux Security Advisory 200503-6 (PacketStormID:F36449)
2005-03-04 00:00:00
Gentoo  security.gentoo.org
advisory
linux,gentoo
CVE-2005-0158
[点击下载]

Gentoo Linux Security Advisory GLSA 200503-06 - Ulf Harnhammar discovered a format string vulnerability in netstuff.cpp. Versions less than 1.3.17 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200503-06
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: BidWatcher: Format string vulnerability
      Date: March 03, 2005
      Bugs: #82460
        ID: 200503-06

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

BidWatcher is vulnerable to a format string vulnerability, potentially
allowing arbitrary code execution.

Background
==========

BidWatcher is a free auction tool for eBay users to keep track of their
auctions.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /  Vulnerable  /                  Unaffected
    -------------------------------------------------------------------
  1  net-misc/bidwatcher      < 1.3.17                       >= 1.3.17

Description
===========

Ulf Harnhammar discovered a format string vulnerability in
"netstuff.cpp".

Impact
======

Remote attackers can potentially exploit this vulnerability by sending
specially crafted responses via an eBay HTTP server or a
man-in-the-middle attack to execute arbitrary malicious code.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All BidWatcher users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-misc/bidwatcher-1.13.17"

References
==========

  [ 1 ] CAN-2005-0158
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0158

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200503-06.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
    

- 漏洞信息 (F36241)

dsa-687.txt (PacketStormID:F36241)
2005-02-25 00:00:00
 
advisory,web
linux,debian
CVE-2005-0158
[点击下载]

Debian Security Advisory 687-1 - The Debian Security Audit Project discovered a format string vulnerability in bidwatcher, a tool for watching and bidding on eBay auctions. This problem can be triggered remotely by a web server of eBay, or someone pretending to be eBay, sending certain data back. As of version 1.3.17 the program uses cURL and is not vulnerable anymore.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 687-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
February 18th, 2005                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : bidwatcher
Vulnerability  : format string
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2005-0158

Ulf H    

- 漏洞信息

13919
Bidwatcher netstuff.cpp Remote Format String
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-02-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.3.17 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Bidwatcher Remote Format String Vulnerability
Input Validation Error 12590
Yes No
2005-02-18 12:00:00 2009-07-12 10:06:00
Ulf Harnhammar is credited with the discovery of this issue.

- 受影响的程序版本

Gentoo Linux
bidwatcher bidwatcher 1.3.16
bidwatcher bidwatcher 1.3.15
bidwatcher bidwatcher 1.3.14
bidwatcher bidwatcher 1.3.13
bidwatcher bidwatcher 1.3.12
bidwatcher bidwatcher 1.3.11
bidwatcher bidwatcher 1.3.10
bidwatcher bidwatcher 1.3.9
bidwatcher bidwatcher 1.3.8
bidwatcher bidwatcher 1.3.7
bidwatcher bidwatcher 1.3.6
bidwatcher bidwatcher 1.3.5
bidwatcher bidwatcher 1.3.4
bidwatcher bidwatcher 1.3.3
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
bidwatcher bidwatcher 1.3.2
bidwatcher bidwatcher 1.3.1
bidwatcher bidwatcher 1.3
bidwatcher bidwatcher 1.3.17

- 不受影响的程序版本

bidwatcher bidwatcher 1.3.17

- 漏洞讨论

A remote format string vulnerability affects bidwatcher. This issue is due to a failure of the application to properly implement a formatted string function.

An attacker may leverage this issue to execute arbitrary code on an affected computer with the privileges of an unsuspecting user that activated the vulnerable application. This may facilitate unauthorized access or privilege escalation.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has released an upgrade dealing with this issue.

Debian Linux has released advisory DSA 687-1 along with fixes dealing with this issue. For more information, please see the referenced advisory.

Gentoo has released an advisory (GLSA 200503-06) and an updated eBuild to address this vulnerability. Gentoo users that are running the affected software may apply the update by issuing the following sequence of commands as a superuser:
emerge --sync
emerge --ask --oneshot --verbose ">=net-misc/bidwatcher-1.13.17"


bidwatcher bidwatcher 1.3

bidwatcher bidwatcher 1.3.1

bidwatcher bidwatcher 1.3.10

bidwatcher bidwatcher 1.3.11

bidwatcher bidwatcher 1.3.12

bidwatcher bidwatcher 1.3.13

bidwatcher bidwatcher 1.3.14

bidwatcher bidwatcher 1.3.15

bidwatcher bidwatcher 1.3.16

bidwatcher bidwatcher 1.3.2

bidwatcher bidwatcher 1.3.3

bidwatcher bidwatcher 1.3.4

bidwatcher bidwatcher 1.3.5

bidwatcher bidwatcher 1.3.6

bidwatcher bidwatcher 1.3.7

bidwatcher bidwatcher 1.3.8

bidwatcher bidwatcher 1.3.9

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站