CVE-2005-0130
CVSS7.5
发布时间 :2005-04-14 00:00:00
修订时间 :2016-10-17 23:08:00
NMCO    

[原文]Certain Perl scripts in Konversation 0.15 allow remote attackers to execute arbitrary commands via shell metacharacters in (1) channel names or (2) song names that are not properly quoted when the user runs IRC sripts.


[CNNVD]Konversation Perl 脚本可执行任意命令漏洞(CNNVD-200504-054)

        konversation是一款KDE包含的IRC客户端软件。
        在Konversation 0.15的某个perl脚本中,当用户运行IRC脚本时,远程攻者可以通过没有正确引用SHELL元字符的频道名或歌曲名来执行任意的命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0130
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0130
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200504-054
(官方数据源) CNNVD

- 其它链接及资源

http://lists.grok.org.uk/pipermail/full-disclosure/2005-January/031033.html
(UNKNOWN)  FULLDISC  20050119 Multiple vulnerabilities in Konversation
http://marc.info/?l=bugtraq&m=110626383310742&w=2
(UNKNOWN)  BUGTRAQ  20050119 Multiple vulnerabilities in Konversation
http://securitytracker.com/id?1012972
(UNKNOWN)  SECTRACK  1012972
http://www.gentoo.org/security/en/glsa/glsa-200501-34.xml
(UNKNOWN)  GENTOO  GLSA-200501-34
http://www.kde.org/info/security/advisory-20050121-1.txt
(UNKNOWN)  CONFIRM  http://www.kde.org/info/security/advisory-20050121-1.txt
http://www.securityfocus.com/bid/12312
(UNKNOWN)  BID  12312
http://xforce.iss.net/xforce/xfdb/19008
(VENDOR_ADVISORY)  XF  konversation-perlscript-execute-code(19008)

- 漏洞信息

Konversation Perl 脚本可执行任意命令漏洞
高危 资料不足
2005-04-14 00:00:00 2005-10-20 00:00:00
远程  
        konversation是一款KDE包含的IRC客户端软件。
        在Konversation 0.15的某个perl脚本中,当用户运行IRC脚本时,远程攻者可以通过没有正确引用SHELL元字符的频道名或歌曲名来执行任意的命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        ftp://ftp.kde.org/pub/kde/security_patches

- 漏洞信息

13116
Konversation Scripts Arbitrary Command Injection

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-19 Unknow
2005-01-19 Unknow

- 解决方案

Upgrade to version 0.15.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站