CVE-2005-0127
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:23
NMCOS    

[原文]Mail in Mac OS X 10.3.7, when generating a Message-ID header, generates a GUUID that includes information that identifies the Ethernet hardware being used, which allows remote attackers to link mail messages to a particular machine.


[CNNVD]Apple Mail信息泄露漏洞(CNNVD-200505-185)

        Mac OS X 10.3.7的Mail,当生成一个Message-ID头时,会生成GUUID,该GUUID包含用于识别要使用的Ethernet硬件的信息,从而远程攻击者可以将邮件消息链接到特定的设备中。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.3.7Apple Mac OS X 10.3.7
cpe:/o:apple:mac_os_x_server:10.3.7Apple Mac OS X Server 10.3.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0127
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0127
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-185
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/464662
(VENDOR_ADVISORY)  CERT-VN  VU#464662
http://xforce.iss.net/xforce/xfdb/19085
(VENDOR_ADVISORY)  XF  macos-ethernet-address-disclosure(19085)
http://secunia.com/advisories/14005
(VENDOR_ADVISORY)  SECUNIA  14005
http://lists.apple.com/archives/security-announce/2005/Jan/msg00001.html
(VENDOR_ADVISORY)  APPLE  APPLE-SA-2005-01-25
http://securitytracker.com/id?1013001
(UNKNOWN)  SECTRACK  1013001

- 漏洞信息

Apple Mail信息泄露漏洞
中危 设计错误
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        Mac OS X 10.3.7的Mail,当生成一个Message-ID头时,会生成GUUID,该GUUID包含用于识别要使用的Ethernet硬件的信息,从而远程攻击者可以将邮件消息链接到特定的设备中。

- 公告与补丁

        暂无数据

- 漏洞信息

13182
Max OS X Mail GUUID Mail Header Information Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Unknown

- 漏洞描述

Mac OS X contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when information about the local Ethernet card is used to build the Message-ID header, which will disclose whether any email originated from the same computer resulting in a loss of confidentiality.

- 时间线

2005-01-25 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Apple Mail EMail Message ID Header Information Disclosure Vulnerability
Design Error 12366
Yes No
2005-01-26 12:00:00 2009-07-12 10:06:00
Carl Purvis is credited with the discovery of this issue.

- 受影响的程序版本

Apple Mail
+ Apple Mac OS X 10.3.7
+ Apple Mac OS X 10.3.6
+ Apple Mac OS X 10.3.5
+ Apple Mac OS X 10.3.4
+ Apple Mac OS X 10.3.3
+ Apple Mac OS X 10.3.2
+ Apple Mac OS X 10.3.1
+ Apple Mac OS X 10.3
+ Apple Mac OS X 10.2.8
+ Apple Mac OS X 10.2.7
+ Apple Mac OS X 10.2.6
+ Apple Mac OS X 10.2.5
+ Apple Mac OS X 10.2.4
+ Apple Mac OS X 10.2.3
+ Apple Mac OS X 10.2.2
+ Apple Mac OS X 10.2.1
+ Apple Mac OS X 10.2
+ Apple Mac OS X 10.1.5
+ Apple Mac OS X 10.1.4
+ Apple Mac OS X 10.1.3
+ Apple Mac OS X 10.1.2
+ Apple Mac OS X 10.1.1
+ Apple Mac OS X 10.1
+ Apple Mac OS X 10.1
+ Apple Mac OS X 10.0.4
+ Apple Mac OS X 10.0.3
+ Apple Mac OS X 10.0.2
+ Apple Mac OS X 10.0.1
+ Apple Mac OS X 10.0 3
+ Apple Mac OS X 10.0
+ Apple Mac OS X Server 10.3.7
+ Apple Mac OS X Server 10.3.6
+ Apple Mac OS X Server 10.3.5
+ Apple Mac OS X Server 10.3.4
+ Apple Mac OS X Server 10.3.3
+ Apple Mac OS X Server 10.3.2
+ Apple Mac OS X Server 10.3.1
+ Apple Mac OS X Server 10.3
+ Apple Mac OS X Server 10.2.8
+ Apple Mac OS X Server 10.2.7
+ Apple Mac OS X Server 10.2.6
+ Apple Mac OS X Server 10.2.5
+ Apple Mac OS X Server 10.2.4
+ Apple Mac OS X Server 10.2.3
+ Apple Mac OS X Server 10.2.2
+ Apple Mac OS X Server 10.2.1
+ Apple Mac OS X Server 10.2
+ Apple Mac OS X Server 10.1.5
+ Apple Mac OS X Server 10.1.4
+ Apple Mac OS X Server 10.1.3
+ Apple Mac OS X Server 10.1.2
+ Apple Mac OS X Server 10.1.1
+ Apple Mac OS X Server 10.1
+ Apple Mac OS X Server 10.0
Apple Mac OS X Server 10.3.8
Apple Mac OS X 10.3.8

- 不受影响的程序版本

Apple Mac OS X Server 10.3.8
Apple Mac OS X 10.3.8

- 漏洞讨论

An information disclosure vulnerability affects the email message ID generation of Apple Mail. This issue is due to a design error that causes the application to insecurely generate email message IDs.

An attacker may leverage this issue to identify the specific computer that an email has been sent from, other attacks may also be possible.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Apple Computers has released advisory APPLE-SA-2005-01-25 along with a security update dealing with this and other issues. Please see the referenced advisory for more information.

Apple Computers has released Mac OS X version 10.3.8 dealing with this issue. This upgrade includes the security patches shipped with the referenced security update.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站