CVE-2005-0103
CVSS7.5
发布时间 :2005-01-24 00:00:00
修订时间 :2016-10-17 23:07:51
NMCOP    

[原文]PHP remote file inclusion vulnerability in webmail.php in SquirrelMail before 1.4.4 allows remote attackers to execute arbitrary PHP code by modifying a URL parameter to reference a URL on a remote web server that contains the code.


[CNNVD]SquirrelMail webmail.php 远程文件引用漏洞(CNNVD-200501-269)

        SquirrelMail是一款基于WebMail系统。
        SqurirelMail 1.4.4之前版本中webmail.php存在远程PHP文件注入漏洞。
        远程攻击者可利用URL参数,通过应用远程服务器的代码,执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:squirrelmail:squirrelmail:1.2.9
cpe:/a:squirrelmail:squirrelmail:1.4.3_rc1
cpe:/a:squirrelmail:squirrelmail:1.2.5
cpe:/a:squirrelmail:squirrelmail:1.4.3
cpe:/a:squirrelmail:squirrelmail:1.2.6
cpe:/a:squirrelmail:squirrelmail:1.2.7
cpe:/a:squirrelmail:squirrelmail:1.2.8
cpe:/a:squirrelmail:squirrelmail:1.2.10
cpe:/a:squirrelmail:squirrelmail:1.2.11
cpe:/a:squirrelmail:squirrelmail:1.4
cpe:/a:squirrelmail:squirrelmail:1.2.1
cpe:/a:squirrelmail:squirrelmail:1.0.4
cpe:/a:squirrelmail:squirrelmail:1.2.2
cpe:/a:squirrelmail:squirrelmail:1.4.0
cpe:/a:squirrelmail:squirrelmail:1.0.5
cpe:/a:squirrelmail:squirrelmail:1.2.3
cpe:/a:squirrelmail:squirrelmail:1.4.1
cpe:/a:squirrelmail:squirrelmail:1.2.4
cpe:/a:squirrelmail:squirrelmail:1.4.2
cpe:/a:squirrelmail:squirrelmail:1.2.0
cpe:/a:squirrelmail:squirrelmail:1.4.3a

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10670PHP remote file inclusion vulnerability in webmail.php in SquirrelMail before 1.4.4 allows remote attackers to execute arbitrary PHP code by...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0103
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0103
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200501-269
(官方数据源) CNNVD

- 其它链接及资源

http://lists.apple.com/archives/security-announce/2005/Mar/msg00000.html
(VENDOR_ADVISORY)  APPLE  APPLE-SA-2005-03-21
http://marc.info/?l=bugtraq&m=110702772714662&w=2
(UNKNOWN)  BUGTRAQ  20050129 SquirrelMail Security Advisory
http://www.gentoo.org/security/en/glsa/glsa-200501-39.xml
(UNKNOWN)  GENTOO  GLSA-200501-39
http://www.redhat.com/support/errata/RHSA-2005-099.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:099
http://www.redhat.com/support/errata/RHSA-2005-135.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:135
http://www.squirrelmail.org/security/issue/2005-01-19?PHPSESSID=8af117822fb1ca3aa966a64248b5d223
(VENDOR_ADVISORY)  CONFIRM  http://www.squirrelmail.org/security/issue/2005-01-19?PHPSESSID=8af117822fb1ca3aa966a64248b5d223
http://xforce.iss.net/xforce/xfdb/19037
(UNKNOWN)  XF  squirrelmail-frame-file-include(19037)

- 漏洞信息

SquirrelMail webmail.php 远程文件引用漏洞
高危 输入验证
2005-01-24 00:00:00 2006-09-28 00:00:00
远程  
        SquirrelMail是一款基于WebMail系统。
        SqurirelMail 1.4.4之前版本中webmail.php存在远程PHP文件注入漏洞。
        远程攻击者可利用URL参数,通过应用远程服务器的代码,执行任意PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://squirrelmail.org/download.php

- 漏洞信息 (F35958)

squirrelInclusion.txt (PacketStormID:F35958)
2005-01-30 00:00:00
Jonathan Angliss  squirrelmail.org
advisory,remote,web,php,xss
CVE-2005-0104,CVE-2005-0103
[点击下载]

SquirrelMail Security Advisory - SquirrelMail 1.4.4 has been released to resolve a number of security issues. Manoel Zaninetti reported an issue in src/webmail.php which would allow a crafted URL to include a remote web page. A possible cross site scripting issue exists in src/webmail.php that is only accessible when the PHP installation is running with register_globals set to On.

SquirrelMail Security Advisory
==============================

SquirrelMail 1.4.4 has been released to resolve a number of security
issues disclosed below.  It is strongly recommended that all running
SquirrelMail prior to 1.4.4 upgrade to the latest release.

Remote File Inclusion
---------------------
Manoel Zaninetti reported an issue in src/webmail.php which would allow a
crafted URL to include a remote web page.  This was assigned CAN-2005-0103
by the Common Vulnerabilities and Exposures.

Cross Site Scripting Issues
---------------------------
A possible cross site scripting issue exists in src/webmail.php that is
only accessible when the PHP installation is running with register_globals
set to On.  This issue was uncovered internally by the SquirrelMail
Development team. This isssue was assigned CAN-2005-0104 by the Common
Vulnerabilities and Exposures.

A second issue which was resolved in the 1.4.4-rc1 release was uncovered
and assigned CAN-2004-1036 by the Common Vulnerabilities and Exposures. 
This issue could allow a remote user to send a specially crafted header
and cause execution of script (such as javascript) in the client browser.

Local File Inclusion
--------------------
A possible local file inclusion issue was uncovered by one of our
developers involving custom preference handlers.  This issue is only
active if the PHP installation is running with register_globals set to On.


It is strongly suggested that all users running SquirrelMail prior to
1.4.4 upgrade to the latest release.  Those using a development release,
should upgrade to the latest snapshots to ensure they have the latest
updates for these issues.  A full list of changes in this, and previous
releases can be found here (http://www.squirrelmail.org/changelog.php).

For further updates on security issues, details are posted to
http://www.squirrelmail.org/security/.  Any security issues should be
emailed to security@squirrelmail.org.

We'd like to express thanks for those that have worked with us on getting
security issues resolved with SquirrelMail, and hope that people continue
to do so in such fashion, it is much appreciated.

-- 
Jonathan Angliss
SquirrelMail Development Team

    

- 漏洞信息

13146
SquirrelMail Frameset Arbitrary HTML Inclusion

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-19 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站