CVE-2005-0098
CVSS4.6
发布时间 :2005-03-08 00:00:00
修订时间 :2008-09-05 16:45:18
NMCOPS    

[原文]Multiple buffer overflows in the SDL port of abuse (abuse-SDL) before 2.00 allow local users to execute arbitrary code via the command line.


[CNNVD]abuse-SDL 多个缓冲区溢出漏洞(CNNVD-200503-082)

        The SDL port of abuse (abuse-SDL) 2.00之前版本存在多个缓冲区溢出,本地用户可以通过命令行执行任意代码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0098
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0098
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200503-082
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-691
(VENDOR_ADVISORY)  DEBIAN  DSA-691
http://secunia.com/advisories/14495
(VENDOR_ADVISORY)  SECUNIA  14495

- 漏洞信息

abuse-SDL 多个缓冲区溢出漏洞
中危 缓冲区溢出
2005-03-08 00:00:00 2006-08-03 00:00:00
本地  
        The SDL port of abuse (abuse-SDL) 2.00之前版本存在多个缓冲区溢出,本地用户可以通过命令行执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Abuse Abuse 2.0
        Debian abuse_2.00+-3woody4_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_alpha.deb
        Debian abuse_2.00+-3woody4_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_arm.deb
        Debian abuse_2.00+-3woody4_hppa.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_hppa.deb
        Debian abuse_2.00+-3woody4_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_i386.deb
        Debian abuse_2.00+-3woody4_ia64.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_ia64.deb
        Debian abuse_2.00+-3woody4_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_m68k.deb
        Debian abuse_2.00+-3woody4_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_mips.deb
        Debian abuse_2.00+-3woody4_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_mipsel.deb
        Debian abuse_2.00+-3woody4_powerpc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_powerpc.deb
        Debian abuse_2.00+-3woody4_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_s390.deb
        Debian abuse_2.00+-3woody4_sparc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/abuse/abuse_2.00+-3woody4_sparc.deb

- 漏洞信息 (F36499)

dsa-691.txt (PacketStormID:F36499)
2005-03-15 00:00:00
 
advisory,vulnerability
linux,debian
CVE-2005-0098,CVE-2005-0099
[点击下载]

Debian Security Advisory 691-1 - Several vulnerabilities have been discovered in abuse, the SDL port of the Abuse action game.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 691-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
March 7th, 2005                         http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : abuse
Vulnerability  : several
Problem-Type   : local
Debian-specific: no
CVE ID         : CAN-2005-0098 CAN-2005-0099

Several vulnerabilities have been discovered in abuse, the SDL port of
the Abuse action game.  The Common Vulnerabilities and Exposures
project identifies the following problems:

CAN-2005-0098

    Erik Sj    

- 漏洞信息

14609
Abuse-SDL Multiple Unspecified Command Line Overflows
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A local overflow exists in Abuse-SDL. The application fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted request, a malicious user can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-03-07 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.00+-3woody4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Abuse Multiple Local Privilege Escalation Vulnerabilities
Unknown 12734
No Yes
2005-03-07 12:00:00 2009-07-12 10:56:00
Discovery of the buffer overflow vulnerabilities is credited to Erik Sj?lund, Steve Kemp is credited with the discovery of the file corruption vulnerability.

- 受影响的程序版本

Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Abuse Abuse 2.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha

- 漏洞讨论

Abuse is reported prone to multiple vulnerabilities. The following individual issues are reported:

Abuse is reported prone to multiple local buffer overflow vulnerabilities.

It is reported that a local attacker may exploit these issues to execute arbitrary code with superuser privileges.

Abuse is also reported prone to an insecure file creation vulnerability. Reports indicate that this issue may be leveraged to overwrite arbitrary files with superuser privileges.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released an advisory (DSA 691-1) and fixes to address these issues. Please peruse the referenced advisory for further details in regard to obtaining and applying fixes.


Abuse Abuse 2.0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站