CVE-2005-0073
CVSS4.6
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:14
NMCOPS    

[原文]Buffer overflow in queue.c in a support script for sympa 3.3.3, when running setuid, allows local users to execute arbitrary code.


[CNNVD]Sympa 未明缓冲区溢出漏洞(CNNVD-200505-351)

        sympa 3.3.3的支持脚本queue.c中含有缓冲区溢出漏洞,当运行setuid时,允许本地用户执行任意代码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0073
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0073
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-351
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-677
(VENDOR_ADVISORY)  DEBIAN  DSA-677
http://securitytracker.com/id?1013163
(UNKNOWN)  SECTRACK  1013163
http://secunia.com/advisories/14224
(UNKNOWN)  SECUNIA  14224
http://secunia.com/advisories/14217
(UNKNOWN)  SECUNIA  14217

- 漏洞信息

Sympa 未明缓冲区溢出漏洞
中危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        sympa 3.3.3的支持脚本queue.c中含有缓冲区溢出漏洞,当运行setuid时,允许本地用户执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://security.debian.org/pool/updates/main/s/sympa/sympa_3.3.3-3woody2_alpha.deb

- 漏洞信息 (F36154)

dsa-677.txt (PacketStormID:F36154)
2005-02-23 00:00:00
 
advisory,overflow,arbitrary
linux,debian
CVE-2005-0073
[点击下载]

Debian Security Advisory 677-1 - A support script of sympa, a mailing list manager, is running setuid sympa and vulnerable to a buffer overflow. This could potentially lead to the execution of arbitrary code under the sympa user id.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 677-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
February 11th, 2005                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : sympa
Vulnerability  : buffer overflow
Problem-Type   : local
Debian-specific: no
CVE ID         : CAN-2005-0073

Erik Sj    

- 漏洞信息

13707
Sympa src/queue.c queue Utility Local Overflow
Local Access Required Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

A local overflow exists in Sympa Mailing List manager. Sympa fails to a boundary error in the queue utility when processing command line arguments resulting in a buffer overflow. With a specially crafted request, an attacker can cause execution of arbitrary code resulting in a loss of confidentality and/or availability.

- 时间线

2005-02-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Sympa Unspecified Buffer Overflow Vulnerability
Boundary Condition Error 12527
Yes No
2005-02-11 12:00:00 2009-07-12 10:06:00
Discovery is credited to Erik Sjolund.

- 受影响的程序版本

Sympa Sympa 3.3.3
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Debian Linux 3.0

- 漏洞讨论

Sympa is reported prone to an unspecified buffer overflow vulnerability.

It is reported that this vulnerability exists in a support script of Sympa. The affected script runs with setuid sympa privileges.

Further details were not provided, however, this BID will be updated when more information becomes available.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released advisory DSA 677-1 to address this issue. Please see the referenced advisory for more information.


Sympa Sympa 3.3.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站