CVE-2005-0049
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:09
NMCOS    

[原文]Windows SharePoint Services and SharePoint Team Services for Windows Server 2003 does not properly validate an HTTP redirection query, which allows remote attackers to inject arbitrary HTML and web script via a cross-site scripting (XSS) attack, or to spoof the web cache.


[CNNVD]Microsoft Windows Sharepoint服务跨站脚本和伪造攻击漏洞(CNNVD-200505-005)

        Windows SharePoint Services是一款Windows服务器基于WEB的信息共享和文档协作技术。
        Windows SharePoint Services存在跨站脚本和伪造问题,远程攻击者可以利用这个漏洞访问目标用户系统上的任何数据,或修改WEB浏览或代理服务器缓冲。跨站脚本问题需要攻击者诱使用户运行恶意脚本,如果这个恶意脚本被运行,就会以目标用户上下文执行,此漏洞需要用户交互,成功利用此问题攻击者可以访问目标用户系统上任何数据。另外存在伪造问题,允许攻击者利用这个漏洞修改WEB浏览器缓冲和中间代理服务器缓冲,或者放入伪造内容到这些缓冲区中。
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:microsoft:sharepoint_portal_server:2003Microsoft Windows SharePoint Services Windows Server 2003
cpe:/a:microsoft:sharepoint_team_servicesMicrosoft Sharepoint Team Services
cpe:/a:microsoft:sharepoint_portal_server:2003:sp1Microsoft Windows SharePoint Services Windows Server 2003 SP1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0049
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0049
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-005
(官方数据源) CNNVD

- 其它链接及资源

http://www.us-cert.gov/cas/techalerts/TA05-039A.html
(PATCH)  CERT  TA05-039A
http://www.kb.cert.org/vuls/id/340409
(PATCH)  CERT-VN  VU#340409
http://www.microsoft.com/technet/security/bulletin/ms05-006.mspx
(PATCH)  MS  MS05-006
http://xforce.iss.net/xforce/xfdb/19091
(VENDOR_ADVISORY)  XF  win-sharepoint-services-xss(19091)

- 漏洞信息

Microsoft Windows Sharepoint服务跨站脚本和伪造攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        Windows SharePoint Services是一款Windows服务器基于WEB的信息共享和文档协作技术。
        Windows SharePoint Services存在跨站脚本和伪造问题,远程攻击者可以利用这个漏洞访问目标用户系统上的任何数据,或修改WEB浏览或代理服务器缓冲。跨站脚本问题需要攻击者诱使用户运行恶意脚本,如果这个恶意脚本被运行,就会以目标用户上下文执行,此漏洞需要用户交互,成功利用此问题攻击者可以访问目标用户系统上任何数据。另外存在伪造问题,允许攻击者利用这个漏洞修改WEB浏览器缓冲和中间代理服务器缓冲,或者放入伪造内容到这些缓冲区中。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.microsoft.com/technet/security/bulletin/ms05-006.mspx" target="_blank

- 漏洞信息

13595
Microsoft Windows Sharepoint Services HTML Redirection XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Windows Sharepoint Services contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate input that is provided to a HTML redirection query before it sends this input to the browser. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-02-08 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Microsoft has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Microsoft Windows SharePoint Services Cross-Site Scripting and Spoofing Vulnerability
Input Validation Error 12476
Yes No
2005-02-08 12:00:00 2009-07-12 10:06:00
The discoverer of this vulnerability is currently unknown. Microsoft reported this issue.

- 受影响的程序版本

Microsoft Windows SharePoint Services Windows Server 2003 SP1
+ Microsoft Windows Server 2003 Datacenter Edition
+ Microsoft Windows Server 2003 Enterprise Edition
+ Microsoft Windows Server 2003 Standard Edition
+ Microsoft Windows Server 2003 Web Edition
Microsoft Windows SharePoint Services Windows Server 2003
+ Microsoft Windows Server 2003 Datacenter Edition
+ Microsoft Windows Server 2003 Enterprise Edition
+ Microsoft Windows Server 2003 Standard Edition
+ Microsoft Windows Server 2003 Web Edition
Microsoft SharePoint Team Services from Microsoft
+ Microsoft FrontPage 2002
- Microsoft IIS 5.0

- 漏洞讨论

A cross-site scripting and spoofing vulnerability affects Microsoft Windows SharePoint Services and SharePoint Team Services.

A remote attacker may carry out a cross-site scripting attack to execute arbitrary HTML and script code in a user's browser. It is also possible to poison Web browser and intermediate proxy server caches by placing spoofed content in the caches.

- 漏洞利用

An exploit is not required to leverage this issue.

- 解决方案

Microsoft has released updates to address this vulnerability on supported platforms.


Microsoft SharePoint Team Services from Microsoft

Microsoft Windows SharePoint Services Windows Server 2003 SP1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站