CVE-2005-0020
CVSS7.2
发布时间 :2005-04-14 00:00:00
修订时间 :2008-09-10 15:34:46
NMCOPS    

[原文]Buffer overflow in playmidi before 2.4 allows local users to execute arbitrary code.


[CNNVD]PlayMidi本地缓冲区溢出漏洞(CNNVD-200504-065)

        PLAYMIDI 是专用于播放MIDI格式文件的工具软件。
        Playmidi的2.4之前版本存在缓冲区溢出,本地用户能够借此执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:mandrakesoft:mandrake_linux:10.1MandrakeSoft Mandrake Linux 10.1
cpe:/o:mandrakesoft:mandrake_linux:10.0::amd64
cpe:/a:playmidi:playmidi:2.3.9
cpe:/a:playmidi:playmidi:2.3.7
cpe:/a:playmidi:playmidi:2.3.6
cpe:/a:playmidi:playmidi:2.3.4
cpe:/o:mandrakesoft:mandrake_linux:10.1::x86_64
cpe:/a:playmidi:playmidi:2.3.16
cpe:/a:playmidi:playmidi:2.3.19
cpe:/a:playmidi:playmidi:2.3.20
cpe:/a:playmidi:playmidi:2.3.3
cpe:/a:playmidi:playmidi:2.3.14
cpe:/a:playmidi:playmidi:2.3.13
cpe:/a:playmidi:playmidi:2.3.22
cpe:/a:playmidi:playmidi:2.3.24
cpe:/a:playmidi:playmidi:2.3.26
cpe:/a:playmidi:playmidi:2.3.2
cpe:/a:playmidi:playmidi:2.3.12
cpe:/a:playmidi:playmidi:2.3.23
cpe:/a:playmidi:playmidi:2.3.18
cpe:/a:playmidi:playmidi:2.3.11
cpe:/a:playmidi:playmidi:2.3.10
cpe:/a:playmidi:playmidi:2.3.25
cpe:/a:playmidi:playmidi:2.3.25.1
cpe:/o:mandrakesoft:mandrake_linux_corporate_server:3.0MandrakeSoft Mandrake Corporate Server 3.0
cpe:/a:playmidi:playmidi:2.3.17
cpe:/a:playmidi:playmidi:2.3.15
cpe:/a:playmidi:playmidi:2.3.1
cpe:/o:mandrakesoft:mandrake_linux:10.0MandrakeSoft Mandrake Linux 10.0
cpe:/a:playmidi:playmidi:2.3.8
cpe:/a:playmidi:playmidi:2.3.5
cpe:/a:playmidi:playmidi:2.3.21

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0020
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0020
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200504-065
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-641
(VENDOR_ADVISORY)  DEBIAN  DSA-641
http://xforce.iss.net/xforce/xfdb/18933
(VENDOR_ADVISORY)  XF  playmidi-bo(18933)
http://www.securityfocus.com/bid/12274
(UNKNOWN)  BID  12274
http://www.osvdb.org/13049
(UNKNOWN)  OSVDB  13049
http://www.mandriva.com/security/advisories?name=MDKSA-2005:010
(UNKNOWN)  MANDRAKE  MDKSA-2005:010
http://securitytracker.com/id?1012957
(UNKNOWN)  SECTRACK  1012957
http://secunia.com/advisories/13898
(UNKNOWN)  SECUNIA  13898
http://secunia.com/advisories/13890
(UNKNOWN)  SECUNIA  13890
http://secunia.com/advisories/13828
(UNKNOWN)  SECUNIA  13828

- 漏洞信息

PlayMidi本地缓冲区溢出漏洞
高危 缓冲区溢出
2005-04-14 00:00:00 2005-10-20 00:00:00
本地  
        PLAYMIDI 是专用于播放MIDI格式文件的工具软件。
        Playmidi的2.4之前版本存在缓冲区溢出,本地用户能够借此执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Playmidi Linux Midi Player 2.4
        Debian playmidi_2.4-4woody1_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_alpha.deb
        Debian playmidi_2.4-4woody1_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_arm.deb
        Debian playmidi_2.4-4woody1_hppa.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_hppa.deb
        Debian playmidi_2.4-4woody1_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_i386.deb
        Debian playmidi_2.4-4woody1_ia64.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_ia64.deb
        Debian playmidi_2.4-4woody1_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_m68k.deb
        Debian playmidi_2.4-4woody1_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_mips.deb
        Debian playmidi_2.4-4woody1_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_mipsel.deb
        Debian playmidi_2.4-4woody1_powerpc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_powerpc.deb
        Debian playmidi_2.4-4woody1_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_s390.deb
        Debian playmidi_2.4-4woody1_sparc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/p/playmidi/playmidi_2.4-4 woody1_sparc.deb
        

- 漏洞信息 (F35782)

dsa-641.txt (PacketStormID:F35782)
2005-01-18 00:00:00
 
advisory,overflow,local,root
linux,debian
CVE-2005-0020
[点击下载]

Debian Security Advisory 641-1 - A MIDI player named playmidi contains a setuid root program with a buffer overflow that can be exploited by a local attacker.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 641-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 17th, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : playmidi
Vulnerability  : buffer overflow
Problem-Type   : local
Debian-specific: no
CVE ID         : CAN-2005-0020

Erik Sj    

- 漏洞信息

13049
Playmidi playmidi.c File Name Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A local overflow exists in Playmidi. The application fails to perform proper bounds checking resulting in a buffer overflow. With a specially crafted file name, a malicious user can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-01-17 Unknow
Unknow Unknow

- 解决方案

Contact your vendor for an appropriate upgrade. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PlayMidi Local Buffer Overflow Vulnerability
Boundary Condition Error 12274
No Yes
2005-01-17 12:00:00 2009-07-12 05:56:00
Erik Sjölund is credited with the discovery of this issue.

- 受影响的程序版本

Playmidi Linux Midi Player 2.4
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Mandriva Linux Mandrake 10.0 AMD64
Mandriva Linux Mandrake 10.0
MandrakeSoft Corporate Server 3.0

- 漏洞讨论

A local buffer overflow vulnerability affects Playmidi. This issue is due to a failure of the an unspecified setuid utility that is packaged with the Playmidi suite to properly validate the length of user-supplied strings prior to copying them into static process buffers.

This BID will be updated as more information becomes available.

A local attacker may leverage this issue to execute arbitrary instructions with the privileges of the superuser. This may facilitate privilege escalation and potentially unauthorized access.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian linux has made an advisory (DSA 641-1) available dealing with this issue. Please see the referenced advisory for more information.

Mandrake has released an advisory MDKSA-2005:010 to address this issue. Please see the referenced advisory for more information.


Playmidi Linux Midi Player 2.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站