CVE-2005-0016
CVSS7.2
发布时间 :2005-04-14 00:00:00
修订时间 :2008-09-05 16:45:05
NMCOPS    

[原文]Buffer overflow in the exported_display function in xatitv in gatos before 0.0.5 allows local users to execute arbitrary code.


[CNNVD]Gatos xatitv缓冲区溢出漏洞(CNNVD-200504-058)

        gatos是一款用于显示部分ATI显卡图象的程序。
        gatos的0.0.5之前版本中的xatitv的exported_display函数存在缓冲区溢出,本地用户可以借此来执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0016
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0016
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200504-058
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-640
(VENDOR_ADVISORY)  DEBIAN  DSA-640
http://secunia.com/advisories/13884/
(VENDOR_ADVISORY)  SECUNIA  13884
http://xforce.iss.net/xforce/xfdb/18930
(VENDOR_ADVISORY)  XF  gatos-xatitv-bo(18930)

- 漏洞信息

Gatos xatitv缓冲区溢出漏洞
高危 缓冲区溢出
2005-04-14 00:00:00 2005-10-20 00:00:00
本地  
        gatos是一款用于显示部分ATI显卡图象的程序。
        gatos的0.0.5之前版本中的xatitv的exported_display函数存在缓冲区溢出,本地用户可以借此来执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        gatos gatos 0.0.5
        Debian gatos_0.0.5-6woody3_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/g/gatos/gatos_0.0.5-6wood y3_i386.deb
        Debian libgatos-dev_0.0.5-6woody3_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/g/gatos/libgatos-dev_0.0. 5-6woody3_i386.deb
        Debian libgatos0_0.0.5-6woody3_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/g/gatos/libgatos0_0.0.5-6 woody3_i386.deb
        

- 漏洞信息 (F35780)

dsa-640.txt (PacketStormID:F35780)
2005-01-18 00:00:00
 
advisory,overflow
linux,debian
CVE-2005-0016
[点击下载]

Debian Security Advisory 640-1 - A buffer overflow has been discovered in xatitv, one of the programs in the gatos package

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 640-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
January 17th, 2005                      http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : gatos
Vulnerability  : buffer overflow
Problem-Type   : local
Debian-specific: no
CVE ID         : CAN-2005-0016

Erik Sj    

- 漏洞信息

13016
GATOS xatitv exported_display() Local Overflow
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

A local overflow exists in gatos xatitv. Xatitv contains a boundary error in the exported_display() function of xutils.c resulting in a buffer overflow. With a specially crafted request, an attacker can cause privilege escalation and arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-01-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.0.5-6woody3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Gatos xatitv Unspecified Buffer Overflow Vulnerability
Boundary Condition Error 12273
No No
2005-01-17 12:00:00 2009-07-12 09:27:00
Erik Sjölund is credited with the discovery of this issue.

- 受影响的程序版本

gatos gatos 0.0.5
- Debian Linux 3.0 sparc
- Debian Linux 3.0 s/390
- Debian Linux 3.0 ppc
- Debian Linux 3.0 mipsel
- Debian Linux 3.0 mips
- Debian Linux 3.0 m68k
- Debian Linux 3.0 ia-64
- Debian Linux 3.0 ia-32
- Debian Linux 3.0 hppa
- Debian Linux 3.0 arm
- Debian Linux 3.0 alpha
- Debian Linux 3.0

- 漏洞讨论

An unspecified buffer overflow vulnerability affects the gatos xatitv utility, which is setuid by default. This issue is due to a failure of the application to properly validate the length of user-supplied strings prior to copying them into static process buffers.

The details currently available surrounding this issue are insufficient to provide and accurate technical description. It is not known if this issue is triggered by an excessively long command line argument, or by some configuration file parameter, or by some multimedia file parameter.

This BID will be updated as more details are released.

An attacker may leverage this issue to execute arbitrary instructions with the privileges of the superuser. This may potentially lead to privilege escalation or unauthorized access.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released advisory DSA 640-1 along with fixes dealing with this issue. Please see the referenced advisory for more information.


gatos gatos 0.0.5

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站