发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-10 15:34:45

[原文] in Sword 1.5.7a allows remote attackers to execute arbitrary commands via shell metacharacters in a URL.

[CNNVD]SWORD Diatheke脚本任意命令执行漏洞(CNNVD-200505-644)

        Sword 1.5.7a中的diatheke.pl使得远程攻击者可以通过在URL内的shell元字符来执行任意命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  sword-diatheke-command-execution(18997)
(UNKNOWN)  BID  12320

- 漏洞信息

SWORD Diatheke脚本任意命令执行漏洞
高危 输入验证
2005-05-02 00:00:00 2005-10-20 00:00:00
        Sword 1.5.7a中的diatheke.pl使得远程攻击者可以通过在URL内的shell元字符来执行任意命令。

- 公告与补丁

        The SWORD Project SWORD 1.5.3
        Debian diatheke_1.5.3-3woody2_alpha.deb
        Debian GNU/Linux 3.0 alias woody oody2_alpha.deb
        Debian diatheke_1.5.3-3woody2_arm.deb
        Debian GNU/Linux 3.0 alias woody oody2_arm.deb
        Debian diatheke_1.5.3-3woody2_hppa.deb
        Debian GNU/Linux 3.0 alias woody oody2_hppa.deb
        Debian diatheke_1.5.3-3woody2_i386.deb
        Debian GNU/Linux 3.0 alias woody oody2_i386.deb
        Debian diatheke_1.5.3-3woody2_ia64.deb
        Debian GNU/Linux 3.0 alias woody oody2_ia64.deb
        Debian diatheke_1.5.3-3woody2_m68k.deb
        Debian GNU/Linux 3.0 alias woody oody2_m68k.deb
        Debian diatheke_1.5.3-3woody2_mips.deb
        Debian GNU/Linux 3.0 alias woody oody2_mips.deb
        Debian diatheke_1.5.3-3woody2_mipsel.deb
        Debian GNU/Linux 3.0 alias woody oody2_mipsel.deb
        Debian diatheke_1.5.3-3woody2_powerpc.deb
        Debian GNU/Linux 3.0 alias woody oody2_powerpc.deb
        Debian diatheke_1.5.3-3woody2_s390.deb
        Debian GNU/Linux 3.0 alias woody oody2_s390.deb
        Debian diatheke_1.5.3-3woody2_sparc.deb
        Debian GNU/Linux 3.0 alias woody oody2_sparc.deb
        Debian libsword-dev_1.5.3-3woody2_alpha.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_alpha.deb
        Debian libsword-dev_1.5.3-3woody2_arm.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_arm.deb
        Debian libsword-dev_1.5.3-3woody2_hppa.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_hppa.deb
        Debian libsword-dev_1.5.3-3woody2_i386.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_i386.deb
        Debian libsword-dev_1.5.3-3woody2_ia64.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_ia64.deb
        Debian libsword-dev_1.5.3-3woody2_m68k.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_m68k.deb
        Debian libsword-dev_1.5.3-3woody2_mips.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_mips.deb
        Debian libsword-dev_1.5.3-3woody2_mipsel.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_mipsel.deb
        Debian libsword-dev_1.5.3-3woody2_powerpc.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_powerpc.deb
        Debian libsword-dev_1.5.3-3woody2_s390.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_s390.deb
        Debian libsword-dev_1.5.3-3woody2_sparc.deb
        Debian GNU/Linux 3.0 alias woody 3-3woody2_sparc.deb
        Debian libsword-runtime_1.5.3-3woody2_alpha.deb
        Debian GNU/Linux 3.0 alias woody 1.5.3-3woody2_alpha.deb
        Debian libsword-runtime_1.5.3-3woody2_arm.deb
        Debian GNU/Linux 3.0 alias woody 1.5.3-3woody2_arm.deb
        Debian libsword-runtime_1

- 漏洞信息 (F35845)

dsa-650.txt (PacketStormID:F35845)
2005-01-25 00:00:00

Debian Security Advisory 650-1 - Sword, a package for making a bible web site, is susceptible to a remote command execution flaw due to a lack of sanitizing input. Not even your god can save you now.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 650-1                                        Martin Schulze
January 20th, 2005               
- --------------------------------------------------------------------------

Package        : sword
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2005-0015

Ulf H    

- 漏洞信息

SWORD Arbitrary Shell Command Injection
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Sword contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered when is given a specially crafted URL, which provides arbitrary commands. It is possible that the flaw may allow arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-01-20 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

SWORD Diatheke Script Arbitrary Command Execution Vulnerability
Input Validation Error 12320
Yes No
2005-01-20 12:00:00 2009-07-12 10:06:00
Discovery is credited to Ulf Härnhammar.

- 受影响的程序版本

The SWORD Project SWORD 1.5.3
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0

- 漏洞讨论

The Diatheke script is reported prone to an arbitrary command execution vulnerability. This issue presents itself due to insufficient sanitization of user-supplied data.

This issue may allow an attacker to gain unauthorized access to a vulnerable computer by supplying arbitrary commands through unspecified parameters of URI links.

- 漏洞利用

An exploit is not required.

- 解决方案

Debian has released advisory DSA 650-1 to address this issue. Please see the referenced advisory for more information.

The SWORD Project SWORD 1.5.3

- 相关参考