CVE-2005-0012
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:05
NMCOS    

[原文]Format string vulnerability in the a_Interface_msg function in Dillo before 0.8.3-r4 allows remote attackers to execute arbitrary code via format string specifiers in a web page.


[CNNVD]Dillo 式化字符串漏洞(CNNVD-200505-381)

        Dillo 0.8.3-r4之前版本的a_Interface_msg函数中存在格式化字符串漏洞,允许远程攻击者通过Web页面的格式化字符串限定符来执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:dillo:dillo_web_browser:0.5.1
cpe:/a:dillo:dillo_web_browser:0.7
cpe:/a:dillo:dillo_web_browser:0.8.3
cpe:/a:dillo:dillo_web_browser:0.6.2
cpe:/a:dillo:dillo_web_browser:0.7.1
cpe:/a:dillo:dillo_web_browser:0.8.2
cpe:/a:dillo:dillo_web_browser:0.2.4
cpe:/a:dillo:dillo_web_browser:0.7.3
cpe:/a:dillo:dillo_web_browser:0.6
cpe:/a:dillo:dillo_web_browser:0.4
cpe:/a:dillo:dillo_web_browser:0.8.1
cpe:/a:dillo:dillo_web_browser:0.3.1
cpe:/a:dillo:dillo_web_browser:0.7.1.2
cpe:/a:dillo:dillo_web_browser:0.8
cpe:/a:dillo:dillo_web_browser:0.2.3
cpe:/a:dillo:dillo_web_browser:0.3
cpe:/a:dillo:dillo_web_browser:0.6.3
cpe:/a:dillo:dillo_web_browser:0.6.1
cpe:/a:dillo:dillo_web_browser:0.6.4
cpe:/a:dillo:dillo_web_browser:0.6.6
cpe:/a:dillo:dillo_web_browser:0.7.2
cpe:/a:dillo:dillo_web_browser:0.2
cpe:/a:dillo:dillo_web_browser:0.2.1
cpe:/a:dillo:dillo_web_browser:0.2.2
cpe:/a:dillo:dillo_web_browser:0.6.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0012
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0012
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-381
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12203
(PATCH)  BID  12203
http://xforce.iss.net/xforce/xfdb/18807
(VENDOR_ADVISORY)  XF  dillo-capi-format-string(18807)
http://www.gentoo.org/security/en/glsa/glsa-200501-11.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200501-11
http://secunia.com/advisories/13760/
(VENDOR_ADVISORY)  SECUNIA  13760
http://secunia.com/advisories/13764
(UNKNOWN)  SECUNIA  13764

- 漏洞信息

Dillo 式化字符串漏洞
高危 格式化字符串
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        Dillo 0.8.3-r4之前版本的a_Interface_msg函数中存在格式化字符串漏洞,允许远程攻击者通过Web页面的格式化字符串限定符来执行任意代码。

- 公告与补丁

        暂无数据

- 漏洞信息

12783
Dillo Web Browser a_Interface_msg() Remote Format String
Remote / Network Access, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-04 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.8.4-rc1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Dillo Interface Message Format String Vulnerability
Input Validation Error 12203
Yes No
2005-01-09 12:00:00 2009-07-12 09:27:00
Discovery is credited to Tavis Ormandy.

- 受影响的程序版本

Dillo Dillo Web Browser 0.8.3
+ Gentoo Linux
Dillo Dillo Web Browser 0.8.2
Dillo Dillo Web Browser 0.8.1
Dillo Dillo Web Browser 0.8
Dillo Dillo Web Browser 0.7.3
Dillo Dillo Web Browser 0.7.2
Dillo Dillo Web Browser 0.7.1 .2
Dillo Dillo Web Browser 0.7.1
Dillo Dillo Web Browser 0.7
Dillo Dillo Web Browser 0.6.6
Dillo Dillo Web Browser 0.6.5
Dillo Dillo Web Browser 0.6.4
Dillo Dillo Web Browser 0.6.3
Dillo Dillo Web Browser 0.6.2
Dillo Dillo Web Browser 0.6.1
Dillo Dillo Web Browser 0.6
Dillo Dillo Web Browser 0.5.1
Dillo Dillo Web Browser 0.4
Dillo Dillo Web Browser 0.3.1
Dillo Dillo Web Browser 0.3
Dillo Dillo Web Browser 0.2.4
Dillo Dillo Web Browser 0.2.3
Dillo Dillo Web Browser 0.2.2
Dillo Dillo Web Browser 0.2.1
Dillo Dillo Web Browser 0.2

- 漏洞讨论

Dillo Web browser is prone to a format string vulnerability. This issue is exposed when the browser handles messages to the interface.

The vulnerability may be triggered when a user visits a malicious Web page. If successfully exploited, this will result in execution of arbitrary code in the context of the client user.

- 漏洞利用

The following example was provided to demonstrate how this issue may be triggered within a malicious Web page:

<base href="file:/"><img src="%x%x%x">

- 解决方案

Gentoo has released advisory GLSA 200501-11 to provide updates for this issue. Updates may be applied by running the following commands as the superuser:
emerge --sync
emerge --ask --oneshot --verbose ">=www-client/dillo-0.8.3-r4"

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站