CVE-2005-0011
CVSS10.0
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:05
NMCOS    

[原文]Multiple vulnerabilities in fliccd, when installed setuid root as part of the kdeedu Kstars support for Instrument Neutral Distributed Interface (INDI) in KDE 3.3 to 3.3.2, allow local users and remote attackers to execute arbitrary code via stack-based buffer overflows.


[CNNVD]KDE KStars FLICCD 多个缓冲区溢出漏洞(CNNVD-200505-415)

        在KDE 3.3至3.3.2环境下,当安装了setuid root作为kdeedu Kstars对Instrument Neutral Distributed Interface (INDI)提供支持的一部分时,其fliccd中包含的多个漏洞允许本地用户和远程攻击者通过基于堆栈的缓冲区溢出来执行任意代码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:kde:kde:3.3.2
cpe:/o:kde:kde:3.3
cpe:/o:kde:kde:3.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0011
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0011
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-415
(官方数据源) CNNVD

- 其它链接及资源

http://www.kde.org/info/security/advisory-20050215-1.txt
(VENDOR_ADVISORY)  CONFIRM  http://www.kde.org/info/security/advisory-20050215-1.txt
http://secunia.com/advisories/14306
(PATCH)  SECUNIA  14306
http://www.redhat.com/archives/fedora-announce-list/2005-February/msg00044.html
(VENDOR_ADVISORY)  FEDORA  FEDORA-2005-148
http://www.gentoo.org/security/en/glsa/glsa-200502-23.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200502-23

- 漏洞信息

KDE KStars FLICCD 多个缓冲区溢出漏洞
危急 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
远程※本地  
        在KDE 3.3至3.3.2环境下,当安装了setuid root作为kdeedu Kstars对Instrument Neutral Distributed Interface (INDI)提供支持的一部分时,其fliccd中包含的多个漏洞允许本地用户和远程攻击者通过基于堆栈的缓冲区溢出来执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/"

- 漏洞信息

13851
INDI fliccd Multiple Local Overflows
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-02-15 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

KDE KStars FLICCD Utility Multiple Buffer Overflow Vulnerabilities
Boundary Condition Error 12570
Yes Yes
2005-02-16 12:00:00 2009-07-12 10:06:00
Erik Sjolund is credited with the discovery of these issues.

- 受影响的程序版本

Red Hat Fedora Core3
KDE KDE 3.3.2
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.1
+ Debian Linux 3.1
KDE KDE 3.3.1
+ Red Hat Fedora Core3
KDE KDE 3.3
Gentoo Linux

- 漏洞讨论

Multiple buffer overflow vulnerabilities affect KDE KStar fliccd. These issues are due to a failure of the utility to securely copy user-supplied data into process memory.

An attacker may leverage these issues to gain escalated privileges locally and, if the affected utility is run as a daemon, may facilitate remote code execution with superuser privileges.

- 漏洞利用

Currently we are not aware of any exploits for these issues. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

KDE has released a patch dealing with these issues.

Gentoo Linux has released an advisory (GLSA 200502-23) and an updated eBuild to address this vulnerability on Gentoo Linux based computers. A Gentoo user may apply the fix by issuing the following sequence of commands as a superuser:

emerge --sync
emerge --ask --oneshot --verbose ">=kde-base/kdeedu-3.3.2-r1"

Fedora Core 3 advisory FEDORA-2005-148 is available to address this issue. Please see the referenced advisory for more information.


KDE KDE 3.3

KDE KDE 3.3.1

KDE KDE 3.3.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站