CVE-2005-0002
CVSS10.0
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-10 15:34:43
NMCOS    

[原文]poppassd_pam 1.0 and earlier, when changing a user password, does not verify that the user entered the old password correctly, which allows remote attackers to change passwords for arbitrary users.


[CNNVD]POP Password Changer未授权密码更改漏洞(CNNVD-200505-138)

        poppassd_pam 1.0以及较早的版本,当更改用户密码时,并未验证用户输入的旧密码是否正确,从而允许远程攻击者可以更改任意用户的密码。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0002
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0002
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-138
(官方数据源) CNNVD

- 其它链接及资源

http://security.gentoo.org/glsa/glsa-200501-22.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200501-22
http://securitytracker.com/id?1012840
(UNKNOWN)  SECTRACK  1012840
http://secunia.com/advisories/13865
(UNKNOWN)  SECUNIA  13865

- 漏洞信息

POP Password Changer未授权密码更改漏洞
危急 设计错误
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        poppassd_pam 1.0以及较早的版本,当更改用户密码时,并未验证用户输入的旧密码是否正确,从而允许远程攻击者可以更改任意用户的密码。

- 公告与补丁

        暂无数据

- 漏洞信息

12896
POP Password Changer (poppassd_pam) Arbitrary User Remote Password Modification
Remote / Network Access

- 漏洞描述

- 时间线

2005-01-11 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

POP Password Changer Unauthorized Password Change Vulnerability
Design Error 12240
Yes No
2005-01-11 12:00:00 2009-07-12 09:27:00
Discovery is credited to Marcus Hanwell.

- 受影响的程序版本

poppassd_pam poppassd_pam 1.0
+ Gentoo Linux
poppassd_ceti poppassd_ceti 1.0
poppassd_ceti poppassd_ceti 1.8.4

- 不受影响的程序版本

poppassd_ceti poppassd_ceti 1.8.4

- 漏洞讨论

poppassd_pam is reported prone to a vulnerability that may allow remote unauthorized users to change passwords. This issue can potentially allow an attacker to gain superuser privileges on a vulnerable computer.

Reportedly, the application does not check the validity of old passwords before changing a password.

poppassd_pam 1.0 is affected by this vulnerability.

- 漏洞利用

An exploit is not required.

- 解决方案

Gentoo has released an advisory (GLSA 200501-22) to address this issue, encouraging users to migrate to poppassd_ceti 1.8.4. Gentoo users may carry out the following commands to update their computers:

emerge --sync
emerge --ask --oneshot --verbose ">=net-mail/poppassd_ceti-1.8.4"

Please see the referenced Gentoo advisory for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站