CVE-2004-2768
CVSS7.2
发布时间 :2010-06-08 14:30:07
修订时间 :2010-06-18 00:24:45
NMCO    

[原文]dpkg 1.9.21 does not properly reset the metadata of a file during replacement of the file in a package upgrade, which might allow local users to gain privileges by creating a hard link to a vulnerable (1) setuid file, (2) setgid file, or (3) device, a related issue to CVE-2010-2059.


[CNNVD]Debian dpkg权限许可和访问控制漏洞(CNNVD-201006-074)

        在软件包升级对文件进行替换时,dpkg没有正确的重置文件的元数据,本地用户可以通过创建易受攻击的(1)setuid文件,(2)setgid文件,或(3)设备的hard链接,获取特权。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2768
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2768
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-201006-074
(官方数据源) CNNVD

- 其它链接及资源

https://bugzilla.redhat.com/show_bug.cgi?id=598775
(UNKNOWN)  MISC  https://bugzilla.redhat.com/show_bug.cgi?id=598775
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=225692
(UNKNOWN)  CONFIRM  https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=225692
http://xforce.iss.net/xforce/xfdb/59428
(UNKNOWN)  XF  dpkg-setgid-privilege-escalation(59428)
http://www.hackinglinuxexposed.com/articles/20031214.html
(UNKNOWN)  MISC  http://www.hackinglinuxexposed.com/articles/20031214.html
http://lists.jammed.com/ISN/2003/12/0056.html
(UNKNOWN)  MLIST  [isn] 20031215 The mysteriously persistently exploitable program explained.

- 漏洞信息

Debian dpkg权限许可和访问控制漏洞
高危 权限许可和访问控制
2010-06-10 00:00:00 2010-06-17 00:00:00
本地  
        在软件包升级对文件进行替换时,dpkg没有正确的重置文件的元数据,本地用户可以通过创建易受攻击的(1)setuid文件,(2)setgid文件,或(3)设备的hard链接,获取特权。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        S.u.S.E. openSUSE 11.0
        SuSE flash-player-10.1.53.64-1.1.i586.rpm
        http://download.opensuse.org/update/11.0/rpm/i586/flash-player-10.1.53 .64-1.1.i586.rpm
        S.u.S.E. openSUSE 11.1
        SuSE flash-player-10.1.53.64-1.1.1.i586.rpm
        http://download.opensuse.org/update/11.2/rpm/i586/flash-player-10.1.53 .64-1.1.1.i586.rpm
        S.u.S.E. openSUSE 11.2
        SuSE flash-player-10.1.53.64-1.1.1.i586.rpm
        http://download.opensuse.org/update/11.2/rpm/i586/flash-player-10.1.53 .64-1.1.1.i586.rpm
        

- 漏洞信息

66942
dpkg Package Upgrade Metadata Reset Weakness Multiple File Hard Link Local Privilege Escalation
Local Access Required
Loss of Integrity Patch / RCS
Vendor Verified

- 漏洞描述

- 时间线

2003-12-14 Unknow
Unknow Unknow

- 解决方案

Products

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站