发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:45:02

[原文]Cross-site scripting (XSS) vulnerability in the failed login page in Novell iChain before 2.2 build 2.2.113 and 2.3 First Customer Ship (FCS) allows remote attackers to inject arbitrary web script or HTML via url parameter.

[CNNVD]Novell iChain Web Server登录失败页面跨站脚本漏洞(CNNVD-200412-626)

        Novell iChain 2.2 build 2.2.113之前版本和2.3 First Customer Ship (FCS)的登录失败页面存在跨站脚本(XSS)漏洞。远程攻击者可以借助url参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:novell:ichain:2.2Novell iChain 2.2

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  ichain-url-xss(14873)
(UNKNOWN)  BID  9412

- 漏洞信息

Novell iChain Web Server登录失败页面跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2004-12-31 00:00:00
        Novell iChain 2.2 build 2.2.113之前版本和2.3 First Customer Ship (FCS)的登录失败页面存在跨站脚本(XSS)漏洞。远程攻击者可以借助url参数注入任意web脚本或HTML。

- 公告与补丁

        Novell has released Technical Information Document (TID2968872) and iChain 2.2 Support Pack 3 Beta 1; this support pack contains a fix to address this and other issues. Please see the referenced Technical Information Document for further details regarding obtaining and applying this support pack.
        The vendor has reported that Novell iChain builds 2.2.113 and later are not prone to this issue. Users are advised to upgrade to the fixed versions by contacting the vendor.

- 漏洞信息

Novell iChain url XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Novell iChain contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "url" variables upon submission to the failed error login pages. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-17 2004-01-12
Unknow Unknow

- 解决方案

Upgrade to version 2.2.113 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete