CVE-2004-2752
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:45:01
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the Downloads module in PostNuke up to 0.726, and possibly later versions, allows remote attackers to inject arbitrary HTML and web script via the ttitle parameter in a viewdownloaddetails action.


[CNNVD]PostNuke SQL注入漏洞(CNNVD-200412-172)

        PostNuke 0.726之前的版本以及可能后来的版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助viewdownloaddetails行为中的ttitle参数注入任意HTML和web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2752
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2752
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-172
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1008629
(PATCH)  SECTRACK  1008629
http://www.derkeiler.com/Mailing-Lists/securityfocus/bugtraq/2004-01/0015.html
(UNKNOWN)  BUGTRAQ  20040102 PostNuke Issues (0.726 && Possibly Older)

- 漏洞信息

PostNuke SQL注入漏洞
中危 跨站脚本
2004-12-31 00:00:00 2004-12-31 00:00:00
远程  
        PostNuke 0.726之前的版本以及可能后来的版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助viewdownloaddetails行为中的ttitle参数注入任意HTML和web脚本。

- 公告与补丁

        

- 漏洞信息

3340
PostNuke Downloads Module ttitle Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PostNuke contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "ttitle" variable upon submission to the Download module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-03 2003-01-04
2004-01-03 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站