CVE-2004-2740
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 00:00:00
NMCO    

[原文]PHP remote file inclusion vulnerability in authform.inc.php in PHProjekt 4.2.3 and earlier allows remote attackers to include arbitrary PHP code via a URL in the path_pre parameter.


[CNNVD]PHProjekt远程文件包含漏洞(CNNVD-200412-420)

        PHProjekt 4.2.3版本及之前版本中的authform.inc.php存在PHP远程文件包含漏洞。远程攻击者可以借助path_pre参数中的URL包括任意PHP代码。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-94 [对生成代码的控制不恰当(代码注入)]

- CPE (受影响的平台与产品)

cpe:/a:phprojekt:phprojekt:3.0
cpe:/a:phprojekt:phprojekt:2.0.1
cpe:/a:phprojekt:phprojekt:2.4
cpe:/a:phprojekt:phprojekt:3.2
cpe:/a:phprojekt:phprojekt:3.1
cpe:/a:phprojekt:phprojekt:2.1
cpe:/a:phprojekt:phprojekt:3.1a
cpe:/a:phprojekt:phprojekt:2.2
cpe:/a:phprojekt:phprojekt:2.4a
cpe:/a:phprojekt:phprojekt:2.3
cpe:/a:phprojekt:phprojekt:4.2
cpe:/a:phprojekt:phprojekt:2.1a
cpe:/a:phprojekt:phprojekt:2.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2740
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2740
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-420
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/13660
(VENDOR_ADVISORY)  SECUNIA  13660
http://xforce.iss.net/xforce/xfdb/18683
(UNKNOWN)  XF  phprojekt-pathpre-file-include(18683)
http://www.securityfocus.com/bid/12116
(UNKNOWN)  BID  12116
http://www.phprojekt.com/modules.php?op=modload&name=News&file=article&sid=193
(UNKNOWN)  CONFIRM  http://www.phprojekt.com/modules.php?op=modload&name=News&file=article&sid=193
http://www.osvdb.org/12613
(UNKNOWN)  OSVDB  12613
http://www.gentoo.org/security/en/glsa/glsa-200412-27.xml
(UNKNOWN)  GENTOO  GLSA-200412-27
http://securitytracker.com/id?1012708
(UNKNOWN)  SECTRACK  1012708

- 漏洞信息

PHProjekt远程文件包含漏洞
中危 代码注入
2004-12-31 00:00:00 2007-10-10 00:00:00
远程  
        PHProjekt 4.2.3版本及之前版本中的authform.inc.php存在PHP远程文件包含漏洞。远程攻击者可以借助path_pre参数中的URL包括任意PHP代码。

- 公告与补丁

        Gentoo has released advisory GLSA 200412-27 to provide fixes for this issue. Fixes may be applied by running the following commands as the superuser:
        emerge --sync
        emerge --ask --oneshot --verbose ">=www-apps/phprojekt-4.2-r2"
        The vendor has released an upgrade dealing with this issue.
        PHProjekt PHProjekt 3.0
        
        PHProjekt PHProjekt 3.1
        
        PHProjekt PHProjekt 3.1 a
        
        PHProjekt PHProjekt 3.2 a
        
        PHProjekt PHProjekt 3.2
        
        PHProjekt PHProjekt 4.2
        
        PHProjekt PHProjekt 4.2.1
        
        PHProjekt PHProjekt 4.2.2
        

- 漏洞信息

12613
PHProjekt authform.inc.php path_pre Variable Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

PHProjekt contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to authform.inc.php not properly sanitizing user input supplied to the path_pre variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2004-12-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.2.3 or higher, as it has been reported to fix this vulnerability. In addition, Albrecht Günther has released a patch for some older versions.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站