CVE-2004-2739
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 00:00:00
NMCO    

[原文]The setup routine (setup.php) in PHProjekt 4.2.1 and earlier allows remote attackers to modify system configuration via unknown attack vectors.


[CNNVD]PHProjekt未明认证绕过漏洞(CNNVD-200412-196)

        PHProjekt 4.2.1版本及之前版本中的设置程序(setup.php)存在漏洞。远程攻击者可以借助未知的攻击向量来修改系统配置。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:phprojekt:phprojekt:3.0
cpe:/a:phprojekt:phprojekt:2.4
cpe:/a:phprojekt:phprojekt:2.0.1
cpe:/a:phprojekt:phprojekt:3.2
cpe:/a:phprojekt:phprojekt:3.1
cpe:/a:phprojekt:phprojekt:2.1
cpe:/a:phprojekt:phprojekt:3.1a
cpe:/a:phprojekt:phprojekt:2.2
cpe:/a:phprojekt:phprojekt:2.1a
cpe:/a:phprojekt:phprojekt:2.0
cpe:/a:phprojekt:phprojekt:2.4a
cpe:/a:phprojekt:phprojekt:2.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2739
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2739
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-196
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/13355
(VENDOR_ADVISORY)  SECUNIA  13355
http://xforce.iss.net/xforce/xfdb/18320
(UNKNOWN)  XF  phprojekt-setup-command-execution(18320)
http://www.securityfocus.com/bid/11797
(UNKNOWN)  BID  11797
http://www.phprojekt.com/modules.php?op=modload&name=News&file=article&sid=189&mode=thread&order=0
(UNKNOWN)  CONFIRM  http://www.phprojekt.com/modules.php?op=modload&name=News&file=article&sid=189&mode=thread&order=0
http://www.osvdb.org/12174
(UNKNOWN)  OSVDB  12174
http://www.novell.com/linux/security/advisories/2004_04_sr.html
(UNKNOWN)  SUSE  SuSE-SR:2004:004
http://www.gentoo.org/security/en/glsa/glsa-200412-06.xml
(UNKNOWN)  GENTOO  GLSA-200412-06
http://securitytracker.com/id?1012369
(UNKNOWN)  SECTRACK  1012369

- 漏洞信息

PHProjekt未明认证绕过漏洞
高危 权限许可和访问控制
2004-12-31 00:00:00 2007-10-10 00:00:00
远程  
        PHProjekt 4.2.1版本及之前版本中的设置程序(setup.php)存在漏洞。远程攻击者可以借助未知的攻击向量来修改系统配置。

- 公告与补丁

        An updated 'setup.php' file is available to resolve this issue. The vendor advises that this file should be unpacked and should be used to replace the 'setup.php' file in the root directory of the installation:
        http://phprojekt.com/files/4.2/setup.zip
        Gentoo Linux has released an advisory (GLSA 200412-06) and an updated eBuild to address this vulnerability. As a superuser, Gentoo users are advised to execute the following commands in order to apply these updates:
        emerge --sync
        emerge --ask --oneshot --verbose ">=www-apps/phprojekt-4.2-r1"
        SuSE Linux has released a summary report dealing with this issue. Please see the referenced advisory and contact the vendor for information on obtaining the updated packages.

- 漏洞信息

12174
PHProjekt setup.php Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

PHProjekt contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered by an unspecified error in the setup.php script. It is possible that the flaw may allow arbitrary code execution resulting in a loss of integrity.

- 时间线

2004-12-02 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, PHProjekt has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站