发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:57

[原文]nbmember.cgi in Netbilling 2.0 allows remote attackers to obtain sensitive information via the cmd=test option, which can be leveraged to determine the access key.

[CNNVD]Netbilling NBMEMBER脚本信息泄露漏洞(CNNVD-200412-686)

        Netbilling 2.0版本的nbmember.cgi存在漏洞。远程攻击者可以借助cmd=test选项获得敏感信息,该漏洞可以被运用到确定访问密钥。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-78 [OS命令中使用的特殊元素转义处理不恰当(OS命令注入)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  netbilling-information-disclosure(17865)
(UNKNOWN)  BID  11504

- 漏洞信息

Netbilling NBMEMBER脚本信息泄露漏洞
中危 操作系统命令注入
2004-12-31 00:00:00 2007-10-10 00:00:00
        Netbilling 2.0版本的nbmember.cgi存在漏洞。远程攻击者可以借助cmd=test选项获得敏感信息,该漏洞可以被运用到确定访问密钥。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (24700)

Netbilling NBMEMBER Script Information Disclosure Vulnerability (EDBID:24700)
cgi webapps
2004-10-22 Verified
0 ls
N/A [点击下载]

Netbilling 'nbmember.cgi' script is reported prone to an information disclosure vulnerability. This issue may allow remote attackers to gain access to user authentication credentials and potentially sensitive configuration information.		

- 漏洞信息

Netbilling nbmember.cgi cmd Variable Information Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

Netbilling nbmember.cgi contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when providing the 'test' parameter to the script, which could allow a remote attacker to locate the 'members-service.pwd' password file and the 'nbmember.cfg' file that contains the access key. With a specially crafted request containing the access key, a remote attacker could disclose sensitive user information resulting in a loss of confidentiality.

- 时间线

2004-01-09 Unknow
2004-01-09 Unknow

- 解决方案

Upgrade to version 2.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者