发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:57

[原文]Sysinternals PsTools before 2.05, including (1) PsExec before 1.54, (2) PsGetsid before 1.41, (3) PsInfo before 1.61, (4) PsKill before 1.03, (5) PsList before 1.26, (6) PsLoglist before 2.51, (7) PsPasswd before 1.21, (8) PsService before 2.12, (9) PsSuspend before 1.05, and (10) PsShutdown before 2.32, does not properly disconnect from remote IPC$ and ADMIN$ shares, which allows local users to access the shares with elevated privileges by using the existing share mapping.

[CNNVD]Sysinternals PsTools远程未授权访问漏洞(CNNVD-200412-475)

        Pstools是一款命令行的Windows NT/2000系统管理工具。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:microsoft:psservice:2.11Microsoft PsService 2.11
cpe:/a:microsoft:psloglist:2.50Microsoft PsLoglist 2.50
cpe:/a:microsoft:sysinternals_pstools:2.04Microsoft Sysinternals PsTools 2.04
cpe:/a:microsoft:pssuspend:1.04Microsoft PsSuspend 1.04
cpe:/a:microsoft:pskill:1.02Microsoft PsKill 1.02
cpe:/a:microsoft:pslist:1.25Microsoft PsList 1.25
cpe:/a:microsoft:psgetsid:1.40Microsoft PsGetsid 1.40
cpe:/a:microsoft:psshutdown:2.31Microsoft PsShutdown 2.31
cpe:/a:microsoft:psinfo:1.60Microsoft PsInfo 1.60
cpe:/a:microsoft:psexec:1.53Microsoft PsExec 1.53

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  10759
(UNKNOWN)  XF  pstools-gain-admin-access(16743)

- 漏洞信息

Sysinternals PsTools远程未授权访问漏洞
中危 权限许可和访问控制
2004-12-31 00:00:00 2007-10-10 00:00:00
        Pstools是一款命令行的Windows NT/2000系统管理工具。

- 公告与补丁

        Sysinternals Upgrade Pstools 2.05

- 漏洞信息

Sysinternals PsTools Share Mapping Privilege Escalation
Remote / Network Access Authentication Management
Loss of Integrity
Exploit Public

- 漏洞描述

PsTools contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when a legitimate user gains administrative access using one of the tools, and then the tool fails to close the $IPC or $ADMIN share on exit. This flaw may lead to a loss of integrity, as a malicious user can re-use this connection.

- 时间线

2004-07-15 2004-07-15
2004-07-15 Unknow

- 解决方案

Upgrade to version 2.05 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者