CVE-2004-2714
CVSS6.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:54
NMCO    

[原文]Unspecified vulnerability in Window Maker 0.80.2 and earlier allows attackers to perform unknown actions via format string specifiers in a font specification in WMGLOBAL, probably a format string vulnerability.


[CNNVD]Window Maker WMGLOBAL字体规格格式字符串漏洞(CNNVD-200412-647)

        Window Maker 0.80.2版本及之前版本存在未明漏洞。攻击者可以借助WMGLOBAL的字体规格中的格式字符串说明符执行未知行为,该漏洞可能是一个格式字符串漏洞。

- CVSS (基础分值)

CVSS分值: 6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: SINGLE_INSTANCE [--]

- CWE (弱点类目)

CWE-134 []

- CPE (受影响的平台与产品)

cpe:/a:windowmaker:windowmaker:0.20.1.3
cpe:/a:windowmaker:windowmaker:0.61.1
cpe:/a:windowmaker:windowmaker:0.80.2
cpe:/a:windowmaker:windowmaker:0.65.1
cpe:/a:windowmaker:windowmaker:0.63
cpe:/a:windowmaker:windowmaker:0.60.0
cpe:/a:windowmaker:windowmaker:0.80
cpe:/a:windowmaker:windowmaker:0.53
cpe:/a:windowmaker:windowmaker:0.60
cpe:/a:windowmaker:windowmaker:0.62
cpe:/a:windowmaker:windowmaker:0.61
cpe:/a:windowmaker:windowmaker:0.65
cpe:/a:windowmaker:windowmaker:0.63.1
cpe:/a:windowmaker:windowmaker:0.64
cpe:/a:windowmaker:windowmaker:0.62.1
cpe:/a:windowmaker:windowmaker:0.52.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2714
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2714
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-647
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11512
(PATCH)  BID  11512
http://xforce.iss.net/xforce/xfdb/17845
(UNKNOWN)  XF  windowmaker-wmglobal-improper-validation(17845)
http://www.osvdb.org/11108
(UNKNOWN)  OSVDB  11108
http://securitytracker.com/id?1011918
(UNKNOWN)  SECTRACK  1011918
http://secunia.com/advisories/12961
(VENDOR_ADVISORY)  SECUNIA  12961

- 漏洞信息

Window Maker WMGLOBAL字体规格格式字符串漏洞
中危 格式化字符串
2004-12-31 00:00:00 2007-10-10 00:00:00
本地  
        Window Maker 0.80.2版本及之前版本存在未明漏洞。攻击者可以借助WMGLOBAL的字体规格中的格式字符串说明符执行未知行为,该漏洞可能是一个格式字符串漏洞。

- 公告与补丁

        This vulnerability has been addressed in Window Maker 0.90.0.
        Windowmaker Windowmaker 0.20.1 -3
        
        Windowmaker Windowmaker 0.52 -2
        
        Windowmaker Windowmaker 0.53
        
        Windowmaker Windowmaker 0.60
        
        Windowmaker Windowmaker 0.61
        
        Windowmaker Windowmaker 0.61.1
        
        Windowmaker Windowmaker 0.62
        
        Windowmaker Windowmaker 0.62.1
        
        Windowmaker Windowmaker 0.63
        
        Windowmaker Windowmaker 0.63.1
        
        Windowmaker Windowmaker 0.64
        
        Windowmaker Windowmaker 0.65
        
        Windowmaker Windowmaker 0.65.1
        
        Windowmaker Windowmaker 0.80
        
        Windowmaker Windowmaker 0.80.2
        

- 漏洞信息

11108
Window Maker WMGLOBAL Font Specification Unspecified Issue
Location Unknown Input Manipulation, Attack Type Unknown
Impact Unknown
Exploit Unknown Vendor Verified

- 漏洞描述

Window Maker contains a flaw related to the lack of a check of the font specification in WMGLOBAL. No further details have been provided.

- 时间线

2004-10-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.80.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站