CVE-2004-2710
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:54
NMCO    

[原文]Multiple buffer overflows in Gyach Enhanced (Gyach-E) before 1.0.3 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to (1) sending certain typing statuses or (2) setting the chat room status bar to the current chat room name.


[CNNVD]Gyach Enhanced (Gyach-E)多个缓冲区溢出漏洞(CNNVD-200412-273)

        Gyach Enhanced (Gyach-E) 1.0.3以前的版本存在多个缓冲区溢出漏洞。远程攻击者借助与(1)发送某些打字状态,或者(2)设置聊天室状态栏为当前聊天室名称相关的向量导致服务拒绝(崩溃)和可能执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2710
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2710
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-273
(官方数据源) CNNVD

- 其它链接及资源

http://www.phrozensmoke.com/projects/pyvoicechat/changelog.php
(PATCH)  CONFIRM  http://www.phrozensmoke.com/projects/pyvoicechat/changelog.php
http://www.osvdb.org/8971
(UNKNOWN)  OSVDB  8971
http://www.osvdb.org/8970
(UNKNOWN)  OSVDB  8970

- 漏洞信息

Gyach Enhanced (Gyach-E)多个缓冲区溢出漏洞
高危 缓冲区溢出
2004-12-31 00:00:00 2007-10-10 00:00:00
远程  
        Gyach Enhanced (Gyach-E) 1.0.3以前的版本存在多个缓冲区溢出漏洞。远程攻击者借助与(1)发送某些打字状态,或者(2)设置聊天室状态栏为当前聊天室名称相关的向量导致服务拒绝(崩溃)和可能执行任意代码。
        

- 公告与补丁

        

- 漏洞信息

8970
Gyach Enhanced Status Transmission Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Gyach Enhanced contains a flaw related to the handling of actual statuses while typing messages that may allow an attacker to cause a buffer overflow. No further details have been provided.

- 时间线

2004-04-26 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站