发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 00:00:00

[原文]Hastymail 1.0.1 and earlier (stable) and 1.1 and earlier (development) does not send the "attachment" parameter in the Content-Disposition field for attachments, which causes the attachment to be rendered inline by Internet Explorer when the victim clicks the download link, which facilitates cross-site scripting (XSS) and possibly other attacks.

[CNNVD]Hastymail HTML附件脚本执行漏洞(CNNVD-200412-1180)

        Hastymail 1.0.1 以及之前的版本(稳定版)和1.1以及之前的版本(演化版)不能发送附件内容配置字段的"attachment"参数,当受害者点击下载链接时,该漏洞导致Internet Explorer将附件内联呈现,这有利于跨站点脚本(XSS)以及其他可能的攻击。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:microsoft:ieMicrosoft Internet Explorer

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  11022
(UNKNOWN)  XF  hastymail-html-script-execution(17091)
(UNKNOWN)  BUGTRAQ  20040824 Hastymail security update

- 漏洞信息

Hastymail HTML附件脚本执行漏洞
中危 跨站脚本
2004-12-31 00:00:00 2007-10-09 00:00:00
        Hastymail 1.0.1 以及之前的版本(稳定版)和1.1以及之前的版本(演化版)不能发送附件内容配置字段的"attachment"参数,当受害者点击下载链接时,该漏洞导致Internet Explorer将附件内联呈现,这有利于跨站点脚本(XSS)以及其他可能的攻击。

- 公告与补丁

        The vendor has released updates to address this issue.
        Hastymail Hastymail 1.0.1
        Hastymail Hastymail 1.1

- 漏洞信息

Hastymail Attachment Content-Disposition Header XSS
Remote / Network Access Input Manipulation, Misconfiguration
Loss of Integrity Patch / RCS, Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

Hastymail contains a flaw that allows a remote cross site scripting attack. The flaw exists because email attachments are not properly defined in the Content-Disposition HTTP header, which will allow Internet Explorer to open it inline. This could allow a user to inject Javascript or activeX code in the attachement that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-08-24 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.2, 1.2 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the patch provided by the vendor for versions 1.0.1 and 1.1.

- 相关参考

- 漏洞作者