CVE-2004-2695
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 00:00:00
NMCO    

[原文]SQL injection vulnerability in the Authorize.net callback code (subscriptions/authorize.php) in Jelsoft vBulletin 3.0 through 3.0.3 allows remote attackers to execute arbitrary SQL statements via the x_invoice_num parameter. NOTE: this issue might be related to CVE-2006-4267.


[CNNVD]vBulletin SQL远程注入漏洞(CNNVD-200412-920)

        
        vBulletin是一款基于WEB的论坛程序。
        vBulletin对用户提交的参数缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息,或更改数据库。
        vBulletin在使用SQL查询之前,对用户提交给"x_invoice_num"参数的数据缺少充分过滤,提交恶意SQL数据,可更改原有数据库逻辑,获得敏感信息或破坏数据库。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-89 [SQL命令中使用的特殊元素转义处理不恰当(SQL注入)]

- CPE (受影响的平台与产品)

cpe:/a:jelsoft:vbulletin:3.0.1
cpe:/a:jelsoft:vbulletin:3.0.2
cpe:/a:jelsoft:vbulletin:3.0
cpe:/a:jelsoft:vbulletin:3.0_beta_7
cpe:/a:jelsoft:vbulletin:3.0_beta_5
cpe:/a:jelsoft:vbulletin:3.0_beta_4
cpe:/a:jelsoft:vbulletin:3.0_beta_6
cpe:/a:jelsoft:vbulletin:3.0_beta_3
cpe:/a:samba:ppp:2.4.1Samba ppp 2.4.1
cpe:/a:jelsoft:vbulletin:3.0_beta_2
cpe:/a:jelsoft:vbulletin:3.0.3
cpe:/a:jelsoft:vbulletin:3.0_gamma

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2695
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2695
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-920
(官方数据源) CNNVD

- 其它链接及资源

http://www.vbulletin.com/forum/bugs.php?do=view&bugid=3379
(PATCH)  CONFIRM  http://www.vbulletin.com/forum/bugs.php?do=view&bugid=3379
http://xforce.iss.net/xforce/xfdb/17365
(UNKNOWN)  XF  vbulletin-itemnumber-sql-injection(17365)
http://www.vbulletin.com/forum/showthread.php?t=124876
(UNKNOWN)  CONFIRM  http://www.vbulletin.com/forum/showthread.php?t=124876
http://www.securityfocus.com/bid/11193
(UNKNOWN)  BID  11193
http://www.securiteam.com/unixfocus/5BP0E15E0M.html
(UNKNOWN)  MISC  http://www.securiteam.com/unixfocus/5BP0E15E0M.html
http://secunia.com/advisories/12531/
(VENDOR_ADVISORY)  SECUNIA  12531

- 漏洞信息

vBulletin SQL远程注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2007-10-09 00:00:00
远程  
        
        vBulletin是一款基于WEB的论坛程序。
        vBulletin对用户提交的参数缺少充分过滤,远程攻击者可以利用这个漏洞获得敏感信息,或更改数据库。
        vBulletin在使用SQL查询之前,对用户提交给"x_invoice_num"参数的数据缺少充分过滤,提交恶意SQL数据,可更改原有数据库逻辑,获得敏感信息或破坏数据库。
        

- 公告与补丁

        厂商补丁:
        VBulletin
        ---------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        
        http://www.vbulletin.com/forum/attachment.php?attachmentid=11557

- 漏洞信息

9993
vBulletin authorize.php x_invoice_num Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity Patch / RCS
Vendor Verified

- 漏洞描述

Jelsoft Enterprises Limited vBulletin contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the x_invoice_num parameter in the subscriptions/authorize.php script is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-09-15 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Jelsoft Enterprises Limited has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站