发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:51

[原文]The exec_dir PHP patch (php-exec-dir) 4.3.2 through 4.3.7 with safe mode disabled allows remote attackers to bypass restrictions and execute arbitrary commands via a backtick operator, which is not handled using the php_escape_shell_cmd function.


        带有安全模式禁用的exec_dir PHP补丁(php-exec-dir) 4.3.2版本到4.3.7版本存在漏洞。远程攻击者可以借助backtick操作员绕过限制以及执行任意命令,该漏洞使用php_escape_shell_cmd函数时不作用。

- CVSS (基础分值)

CVSS分值: 9.3 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-264| CWE-16 []

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  10598
(UNKNOWN)  XF  phpexecdir-semicolon-restriction-bypass(16498)
(UNKNOWN)  FULLDISC  20040708 Re: php-exec-dir vulnerable after latest upgrade
(UNKNOWN)  FULLDISC  20040708 RE: php-exec-dir vulnerable after latest upgrade
(UNKNOWN)  FULLDISC  20040708 php-exec-dir vulnerable after latest upgrade

- 漏洞信息

高危 权限许可和访问控制
2004-12-31 00:00:00 2007-10-09 00:00:00
        带有安全模式禁用的exec_dir PHP补丁(php-exec-dir) 4.3.2版本到4.3.7版本存在漏洞。远程攻击者可以借助backtick操作员绕过限制以及执行任意命令,该漏洞使用php_escape_shell_cmd函数时不作用。

- 公告与补丁

        It is reported that the vendor has released updates to address this issue. At the time of writing, the website on which the patches are reported to reside is not available. It is reported that the patches may be retrieved from the following site:
        php-exec-dir users are advised to contact the vendor for further information regarding obtaining and applying appropriate patches.
        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (384)

PHP (php-exec-dir) Patch Command Access Restriction Bypass (EDBID:384)
php webapps
2004-08-08 Verified
0 VeNoMouS
N/A [点击下载]
$blah = `& /bin/ps aux`; 
echo nl2br($blah); 

$blah = `| /bin/ps aux`; 
echo nl2br($blah); 

# [2004-08-08]

- 漏洞信息

php-exec-dir Command Execution Bypass
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

php-exec-dir contains a flaw that may allow a malicious user to bypass restrictions and execute commands. The issue is triggered when a user places a ";" before the command they wish to execute. It is possible that the flaw may allow remote command execution resulting in a loss of confidentiality, integrity, and/or availability.

- 时间线

2004-06-24 2004-06-23
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, the vendor has released a patch to address this vulnerability. Please note, the initial patch for this vulnerability did not fully correct the flaw. Be sure you have downloaded the patch on or after 2004 09:47:57.

- 相关参考

- 漏洞作者