发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:47

[原文]Multiple cross-site scripting (XSS) vulnerabilities in mod.php in eNdonesia 8.3 allow remote attackers to inject arbitrary web script or HTML via (1) the mod parameter in a viewcat operation or (2) the query parameter in a search operation in the publisher module.

[CNNVD]eNdonesia Search Form跨站脚本漏洞(CNNVD-200412-1036)

        eNdonesia 8.3版本的mod.php存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)viewcat操作中的mod参数或者(2)publisher模块的search操作中的query参数注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  endonesia-mod-xss(13041)
(VENDOR_ADVISORY)  BUGTRAQ  20040804 Multiple vulnerabilities in eNdonesia CMS

- 漏洞信息

eNdonesia Search Form跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2007-01-05 00:00:00
        eNdonesia 8.3版本的mod.php存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)viewcat操作中的mod参数或者(2)publisher模块的search操作中的query参数注入任意web脚本或者HTML。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (24348)

eNdonesia 8.3 Search Form Cross-Site Scripting Vulnerability (EDBID:24348)
php webapps
2004-08-04 Verified
0 Ahmad Muammar
N/A [点击下载]

It is reported that eNdonesia is susceptible to a cross-site scripting vulnerability. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamically generated web content.

As a result of this vulnerability, it is possible for a remote attacker to create a malicious link containing script code that will be executed in the browser of a legitimate user. Specifically the attacker can pass malicious HTML code as a value for the affected URI parameter supplied to 'mod.php'. All code will be executed within the context of the website running the vulnerable software.

This may allow for theft of cookie-based authentication credentials and other attacks. 

Version 8.3 of the software is reported vulnerable. Other versions may also be affected.		

- 漏洞信息

eNdonesia mod.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

eNdonesia contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'mod' or 'query' variables upon submission to the 'mod.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-08-02 Unknow
2004-08-02 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者