CVE-2004-2632
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:41
NMCO    

[原文]phpMyAdmin 2.5.1 up to 2.5.7 allows remote attackers to modify configuration settings and gain unauthorized access to MySQL servers via modified $cfg['Servers'] variables.


[CNNVD]phpMyAdmin多个输入验证漏洞(CNNVD-200412-539)

        phpMyAdmin 2.5.1至2.5.7版本存在漏洞。远程攻击者通过修改$cfg['Servers']变量修改配置设置且获取MySQL服务器未认证的访问权限。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpmyadmin:phpmyadmin:2.5.7
cpe:/a:phpmyadmin:phpmyadmin:2.5.5_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.5.4
cpe:/a:phpmyadmin:phpmyadmin:2.5.2_pl1
cpe:/a:phpmyadmin:phpmyadmin:2.5.6_rc2
cpe:/a:phpmyadmin:phpmyadmin:2.5.5_rc2
cpe:/a:phpmyadmin:phpmyadmin:2.5.3
cpe:/a:phpmyadmin:phpmyadmin:2.5.2
cpe:/a:phpmyadmin:phpmyadmin:2.5.5
cpe:/a:phpmyadmin:phpmyadmin:2.5.1
cpe:/a:phpmyadmin:phpmyadmin:2.5.5_rc1
cpe:/a:phpmyadmin:phpmyadmin:2.5.6_rc1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2632
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2632
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-539
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10629
(PATCH)  BID  10629
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2004-1
(PATCH)  CONFIRM  http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2004-1
http://www.osvdb.org/7315
(PATCH)  OSVDB  7315
http://www.gentoo.org/security/en/glsa/glsa-200407-22.xml
(PATCH)  GENTOO  GLSA-200407-22
http://secunia.com/advisories/11974
(VENDOR_ADVISORY)  SECUNIA  11974
http://xforce.iss.net/xforce/xfdb/16555
(UNKNOWN)  XF  phpmyadmin-code-manipulation(16555)
http://securitytracker.com/alerts/2004/Jun/1010614.html
(UNKNOWN)  SECTRACK  1010614
http://eagle.kecapi.com/sec/fd/phpMyAdmin.html
(UNKNOWN)  MISC  http://eagle.kecapi.com/sec/fd/phpMyAdmin.html
http://archives.neohapsis.com/archives/bugtraq/2004-06/0473.html
(UNKNOWN)  BUGTRAQ  20040630 Re: php codes injection in phpMyAdmin version 2.5.7.
http://archives.neohapsis.com/archives/bugtraq/2004-06/0444.html
(UNKNOWN)  BUGTRAQ  20040628 php codes injection in phpMyAdmin version 2.5.7.

- 漏洞信息

phpMyAdmin多个输入验证漏洞
高危 输入验证
2004-12-31 00:00:00 2006-06-15 00:00:00
远程  
        phpMyAdmin 2.5.1至2.5.7版本存在漏洞。远程攻击者通过修改$cfg['Servers']变量修改配置设置且获取MySQL服务器未认证的访问权限。
        

- 公告与补丁

        The vendor has released version 2.5.7, patch level 1 addressing this vulnerability. Users of affected packages are urged to upgrade.
        Gentoo has released an advisory (GLSA 200407-22) and an updated eBuild to address the issues that are described in this BID. Gentoo users are advised to perform the following actions as a superuser in order to apply appropriate fixes.
        emerge sync
        emerge -pv ">=dev-db/phpmyadmin-2.5.7_p1"
        emerge ">=dev-db/phpmyadmin-2.5.7_p1"
        phpMyAdmin phpMyAdmin 2.5.1
        
        phpMyAdmin phpMyAdmin 2.5.2
        
        phpMyAdmin phpMyAdmin 2.5.4
        
        phpMyAdmin phpMyAdmin 2.5.5 -rc2
        
        phpMyAdmin phpMyAdmin 2.5.5 pl1
        
        phpMyAdmin phpMyAdmin 2.5.5
        
        phpMyAdmin phpMyAdmin 2.5.5 -rc1
        
        phpMyAdmin phpMyAdmin 2.5.6 -rc1
        
        phpMyAdmin phpMyAdmin 2.5.7
        

- 漏洞信息

7315
phpMyAdmin Arbitrary Database Access
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpMyAdmin contains a flaw that may allow a remote attacker to access arbitrary Databases. By sending configuration parameters to the 'left.php' script, a remote attacker could modify current configuration settings and could gain access to the MySQL server that were not listed in the original configuration file, resulting in a loss of confidentiality.

- 时间线

2004-06-28 Unknow
2004-06-28 Unknow

- 解决方案

Upgrade to version 2.5.7 Patch Level 1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站