发布时间 :2004-12-31 00:00:00
修订时间 :2017-07-19 21:29:02

[原文]Cross-site scripting (XSS) vulnerability in Pegasi Web Server (PWS) 0.2.2 allows remote attackers to inject arbitrary web script or HTML via the URI, directly after the initial '/' (slash).

[CNNVD]Pegasi Web服务器多个输入验证漏洞(CNNVD-200412-337)

        Pegasi Web服务器(PWS)0.2.2版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助初始'/'(斜线)后直接跟着的URI注入任意web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20040311 Multiple Vulnerabilities in PWS 0.2.2
(PATCH)  BUGTRAQ  20040314 Re: Multiple Vulnerabilities in PWS 0.2.2
(PATCH)  BID  9847
(UNKNOWN)  XF  pws-xss(15436)

- 漏洞信息

Pegasi Web服务器多个输入验证漏洞
中危 跨站脚本
2004-12-31 00:00:00 2006-01-19 00:00:00
        Pegasi Web服务器(PWS)0.2.2版本存在跨站脚本(XSS)漏洞。远程攻击者可以借助初始'/'(斜线)后直接跟着的URI注入任意web脚本。

- 公告与补丁

        The vendor has released an update to address the issues described in this BID. Users who are potentially affected are advised to apply this upgrade as soon as possible.
        Pegasi Web Server Pegasi Web Server 0.2.2

- 漏洞信息 (23803)

Pegasi Web Server 0.2.2 Error Page XSS (EDBID:23803)
linux remote
2004-03-11 Verified
0 Donato Ferrante
N/A [点击下载]
Multiple vulnerabilities have been identified in the application that may allow a remote attacker to carry out directory traversal and cross-site scripting attacks. A successful cross-site scripting attack may make it possible for an attacker to create a malicious link to a vulnerable site that includes hostile HTML and script code. This code may be rendered in the browser of a victim user who visits the malicious link and this will occur in the security context of the site hosting the software. The directory traversal vulnerability may allow a malicious user to request files outside of the web-server root directory with directory traversal strings such as '../'.
Pegasi Web Server version 0.2.2 has been reported to be prone to these issues, however, it is possible that other versions are affected as well.<script>alert("Test")</script>		

- 漏洞信息

Pegasi Web Server Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Pegasi Web Server contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the URI passed to the error page. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-11 Unknow
2004-03-11 Unknow

- 解决方案

Upgrade to version 0.2.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者