CVE-2004-2590
CVSS10.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:34
NMCO    

[原文]Unspecified vulnerability in meindlSOFT Cute PHP Library (aka cphplib) 0.46 has unknown impact and attack vectors, related to regular expressions.


[CNNVD]MeindlSOFT Cute PHP Library cphplib输入验证漏洞(CNNVD-200412-743)

        meindlSOFT Cute PHP Library (aka cphplib) 0.46版本存在未明的漏洞。该漏洞导致未知的影响和攻击向量,它和正则表达式有关。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2590
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2590
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-743
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/11062
(PATCH)  BID  11062
http://securitytracker.com/id?1011076
(PATCH)  SECTRACK  1011076
http://xforce.iss.net/xforce/xfdb/17145
(UNKNOWN)  XF  cphplib-parameter-improper-validation(17145)
http://www.osvdb.org/9224
(UNKNOWN)  OSVDB  9224
http://www.meindlsoft.com/cphplib_changelog.php
(UNKNOWN)  CONFIRM  http://www.meindlsoft.com/cphplib_changelog.php
http://prdownloads.sourceforge.net/cphplib/cphplib-0.47.tar.gz?download
(UNKNOWN)  CONFIRM  http://prdownloads.sourceforge.net/cphplib/cphplib-0.47.tar.gz?download

- 漏洞信息

MeindlSOFT Cute PHP Library cphplib输入验证漏洞
危急 设计错误
2004-12-31 00:00:00 2006-01-23 00:00:00
远程  
        meindlSOFT Cute PHP Library (aka cphplib) 0.46版本存在未明的漏洞。该漏洞导致未知的影响和攻击向量,它和正则表达式有关。

- 公告与补丁

        The vendor has released an upgrade dealing with this issue.
        meindlSOFT Cute PHP Library (cphplib) 0.42
        
        meindlSOFT Cute PHP Library (cphplib) 0.43
        
        meindlSOFT Cute PHP Library (cphplib) 0.44
        
        meindlSOFT Cute PHP Library (cphplib) 0.45
        
        meindlSOFT Cute PHP Library (cphplib) 0.46
        

- 漏洞信息

9224
Cute PHP Library Unspecified Regular Expressions Issue
Location Unknown Attack Type Unknown
Impact Unknown
Exploit Unknown

- 漏洞描述

Cute PHP Library contains a flaw related to the regular expressions. No further details have been provided.

- 时间线

2004-08-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.47 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站