CVE-2004-2578
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-10 15:34:06
NMCO    

[原文]phpGroupWare before 0.9.16.002 transmits the (1) header admin and (2) setup passwords in plaintext via cookies, which allows remote attackers to sniff passwords.


[CNNVD]PHPGroupWare Plaintext Cookie身份验证凭据的信息泄露漏洞(CNNVD-200412-721)

        phpGroupWare 0.9.16.002以前的版本借助cookies以明文方式发送(1)header admin和(2)setup密码。远程攻击者利用该漏洞嗅探密码。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpgroupware:phpgroupware:0.9.9_pl1
cpe:/a:phpgroupware:phpgroupware:0.9.8
cpe:/a:phpgroupware:phpgroupware:0.9.7
cpe:/a:phpgroupware:phpgroupware:0.9.5
cpe:/a:phpgroupware:phpgroupware:0.9.16.000
cpe:/a:phpgroupware:phpgroupware:0.9.16.001
cpe:/a:phpgroupware:phpgroupware:0.9.10
cpe:/a:phpgroupware:phpgroupware:0.9.3
cpe:/a:phpgroupware:phpgroupware:0.9.1
cpe:/a:phpgroupware:phpgroupware:0.9.14.006
cpe:/a:phpgroupware:phpgroupware:0.9.2
cpe:/a:phpgroupware:phpgroupware:0.9.9
cpe:/a:phpgroupware:phpgroupware:0.9.13
cpe:/a:phpgroupware:phpgroupware:0.9.6
cpe:/a:phpgroupware:phpgroupware:0.9.14.007
cpe:/a:phpgroupware:phpgroupware:0.9.12
cpe:/a:phpgroupware:phpgroupware:0.9.14.003
cpe:/a:phpgroupware:phpgroupware:0.9.14.005
cpe:/a:phpgroupware:phpgroupware:0.9.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2578
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2578
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-721
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16970
(UNKNOWN)  XF  phpgroupware-plaintext-password(16970)
http://www.securityfocus.com/bid/10895
(UNKNOWN)  BID  10895
http://www.osvdb.org/8354
(UNKNOWN)  OSVDB  8354

- 漏洞信息

PHPGroupWare Plaintext Cookie身份验证凭据的信息泄露漏洞
中危 设计错误
2004-12-31 00:00:00 2007-07-20 00:00:00
远程  
        phpGroupWare 0.9.16.002以前的版本借助cookies以明文方式发送(1)header admin和(2)setup密码。远程攻击者利用该漏洞嗅探密码。

- 公告与补丁

        The vendor has released version 0.9.16.002 addressing this issue.
        PHPGroupWare PHPGroupWare 0.9.12
        
        PHPGroupWare PHPGroupWare 0.9.13
        
        PHPGroupWare PHPGroupWare 0.9.14 .006
        
        PHPGroupWare PHPGroupWare 0.9.14 .005
        
        PHPGroupWare PHPGroupWare 0.9.14 .003
        
        PHPGroupWare PHPGroupWare 0.9.14 .007
        
        PHPGroupWare PHPGroupWare 0.9.16 RC1
        
        PHPGroupWare PHPGroupWare 0.9.16 .000
        

- 漏洞信息

8354
phpGroupWare Admin/Setup Password Cleartext Cookie Storage
Remote / Network Access Cryptographic, Information Disclosure
Loss of Confidentiality
Exploit Unknown

- 漏洞描述

phpGroupWare contains a flaw that may lead to an unauthorized information disclosure.  The problem is that the program sets header admin and setup passwords as plaintext cookies, which will disclose sensitive information resulting in a loss of confidentiality.

- 时间线

2004-07-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.16.002 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站