CVE-2004-2577
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:32
NMCO    

[原文]The acl_check function in phpGroupWare 0.9.16RC2 always returns True, even when mkdir does not behave as expected, which could allow remote attackers to obtain sensitive information via WebDAV from users' home directories that lack .htaccess files, and possibly has other unknown impacts.


[CNNVD]PHPGroupWare ACL_Check漏洞(CNNVD-200412-299)

        即使mkdir并不如预期的行为,
        phpGroupWare 0.9.16RC2的acl_check函数仍常常返回True,远程攻击者借助缺少.htaccess文件的用户主目录的WebDAV获取敏感信息,并且可能有其他未知的影响。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpgroupware:phpgroupware:0.9.16rc1
cpe:/a:phpgroupware:phpgroupware:0.9.16rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2577
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2577
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-299
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12237
(PATCH)  BID  12237
https://savannah.gnu.org/bugs/?func=detailitem&item_id=7227
(UNKNOWN)  CONFIRM  https://savannah.gnu.org/bugs/?func=detailitem&item_id=7227
http://www.osvdb.org/7618
(UNKNOWN)  OSVDB  7618

- 漏洞信息

PHPGroupWare ACL_Check漏洞
中危 设计错误
2004-12-31 00:00:00 2005-12-14 00:00:00
远程  
        即使mkdir并不如预期的行为,
        phpGroupWare 0.9.16RC2的acl_check函数仍常常返回True,远程攻击者借助缺少.htaccess文件的用户主目录的WebDAV获取敏感信息,并且可能有其他未知的影响。
        

- 公告与补丁

        The vendor has reportedly addressed this issue is phpGroupWare 0.9.16RC3 and later.
        PHPGroupWare PHPGroupWare 0.9.16 RC2
        
        PHPGroupWare PHPGroupWare 0.9.16 RC1
        

- 漏洞信息

7618
phpGroupWare acl_check Failure
Remote / Network Access Information Disclosure, Other
Loss of Confidentiality
Exploit Unknown

- 漏洞描述

phpGroupWare contains a flaw related to the "acl_check" function that may allow a remote attacker to bypass authentication settings. No further details have been provided.

- 时间线

2004-01-13 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站