CVE-2004-2574
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2011-03-07 21:19:02
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in index.php in phpGroupWare 0.9.14.005 and earlier allows remote attackers to inject arbitrary web script or HTML via the date parameter in a calendar.uicalendar.planner menuaction.


[CNNVD]PHPGroupWare Index.PHP HTM注入漏洞(CNNVD-200412-783)

        phpGroupWare 0.9.14.005及其更早版本的index.php存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助calendar.uicalendar.planner menuaction中的data参数注入任意web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpgroupware:phpgroupware:0.9.16.000
cpe:/a:phpgroupware:phpgroupware:0.9.16.005
cpe:/a:phpgroupware:phpgroupware:0.9.16.003
cpe:/a:phpgroupware:phpgroupware:0.9.16.002

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2574
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2574
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-783
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12082
(PATCH)  BID  12082
https://savannah.gnu.org/bugs/?func=detailitem&item_id=7478
(UNKNOWN)  CONFIRM  https://savannah.gnu.org/bugs/?func=detailitem&item_id=7478
http://www.osvdb.org/7600
(UNKNOWN)  OSVDB  7600

- 漏洞信息

PHPGroupWare Index.PHP HTM注入漏洞
中危 跨站脚本
2004-12-31 00:00:00 2007-07-20 00:00:00
远程  
        phpGroupWare 0.9.14.005及其更早版本的index.php存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助calendar.uicalendar.planner menuaction中的data参数注入任意web脚本或HTML。

- 公告与补丁

        This issue has reportedly been addressed in phpGroupWare 0.9.16RC3 and later.
        PHPGroupWare PHPGroupWare 0.9.12
        
        PHPGroupWare PHPGroupWare 0.9.13
        
        PHPGroupWare PHPGroupWare 0.9.14 .003
        
        PHPGroupWare PHPGroupWare 0.9.14 .005
        

- 漏洞信息

7600
phpGroupWare index.php Calendar Date Parameter XSS
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpGroupWare contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the "date" variable upon submission to the "index.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-01-27 Unknow
2004-01-27 Unknow

- 解决方案

Upgrade to version 0.9.14.006 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站