CVE-2004-2568
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2011-03-07 21:19:02
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in ReciPants 1.1.1 allow remote attackers to inject arbitrary web script or HTML via the (1) user id, (2) recipe id, (3) category id, and (4) other ID number fields.


[CNNVD]ReciPants SQL注入和跨站脚本漏洞(CNNVD-200412-274)

        ReciPants 1.1.1版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)user id,(2) recipe id,(3) category id,和(4)其他的ID号码字段注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:recipants:recipants:1.0
cpe:/a:recipants:recipants:1.1
cpe:/a:recipants:recipants:1.1.1
cpe:/a:recipants:recipants:1.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2568
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2568
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-274
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10250
(PATCH)  BID  10250
http://www.osvdb.org/5787
(PATCH)  OSVDB  5787
http://sourceforge.net/project/shownotes.php?group_id=90737&release_id=234415
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=90737&release_id=234415
http://securitytracker.com/id?1009984
(PATCH)  SECTRACK  1009984
http://secunia.com/advisories/11533
(VENDOR_ADVISORY)  SECUNIA  11533

- 漏洞信息

ReciPants SQL注入和跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2006-01-24 00:00:00
远程  
        ReciPants 1.1.1版本存在多个跨站脚本(XSS)漏洞。远程攻击者借助(1)user id,(2) recipe id,(3) category id,和(4)其他的ID号码字段注入任意web脚本或者HTML。

- 公告与补丁

        The vendor has released an upgrade dealing with this issue.
        ReciPants ReciPants 1.0
        
        ReciPants ReciPants 1.0.1
        
        ReciPants ReciPants 1.1
        
        ReciPants ReciPants 1.1.1
        

- 漏洞信息

5787
ReciPants Multiple Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

ReciPants contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input in various ID parameters (e. g. user id, recipe id, category id). This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity. No further details have been provided.

- 时间线

2004-04-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站