发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:27

[原文]Multiple cross-site scripting (XSS) vulnerabilities in unspecified Perl scripts in SandSurfer before 1.7.1 allow remote attackers to inject arbitrary web script or HTML, which is later executed by a target who views reports containing the injected data.


        SandSurfer 1.7.1之前版本中的未明Perl脚本存在多个跨站脚本(XSS)漏洞。远程攻击者可以注入任意web脚本或HTML,该漏洞之后被一个查看含注入数据报告的目标所执行。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  BID  9801
(PATCH)  OSVDB  4132
(UNKNOWN)  XF  sandsurfer-xss(15377)

- 漏洞信息

中危 跨站脚本
2004-12-31 00:00:00 2006-01-24 00:00:00
        SandSurfer 1.7.1之前版本中的未明Perl脚本存在多个跨站脚本(XSS)漏洞。远程攻击者可以注入任意web脚本或HTML,该漏洞之后被一个查看含注入数据报告的目标所执行。

- 公告与补丁

        The vendor has released an update to address this issue:
        SandSurfer SandSurfer 1.6.5
        SandSurfer SandSurfer 1.7 .0

- 漏洞信息

SandSurfer Unspecified Multiple XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

SandSurfer contains flaws that allow remote cross site scripting attacks. This flaw exists because the application does not validate some variables upon submission to the unspecified scripts. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-03-01 2004-03-01
Unknow Unknow

- 解决方案

Upgrade to version 1.7.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

SandSurfer Multiple Undisclosed Cross-Site Scripting Vulnerabilities
Input Validation Error 9801
Yes No
2004-03-03 12:00:00 2004-03-03 12:00:00
This vulnerability was announced by pcxuser.

- 受影响的程序版本

SandSurfer SandSurfer 1.7 .0
SandSurfer SandSurfer 1.6.5
SandSurfer SandSurfer 1.7.1

- 不受影响的程序版本

SandSurfer SandSurfer 1.7.1

- 漏洞讨论

It has been reported that a number of undisclosed SandSurfer scripts are prone to cross-site scripting vulnerabilities.

This could permit a remote attacker to create a malicious link to the vulnerable application that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

The vendor has released an update to address this issue:

SandSurfer SandSurfer 1.6.5

SandSurfer SandSurfer 1.7 .0

- 相关参考