CVE-2004-2525
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2011-03-07 21:18:58
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in compat.php in Serendipity before 0.7.1 allows remote attackers to inject arbitrary web script or HTML via the searchTerm variable.


[CNNVD]S9Y Serendipity远程跨站脚本漏洞(CNNVD-200412-876)

        Serendipity 0.7.1之前版本的compat.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助searchTerm变量注入任意web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:s9y:serendipity:0.6_pl2
cpe:/a:s9y:serendipity:0.7_beta4
cpe:/a:s9y:serendipity:0.7_rc1
cpe:/a:s9y:serendipity:0.6
cpe:/a:s9y:serendipity:0.3S9Y Serendipity 0.3
cpe:/a:s9y:serendipity:0.7_beta3
cpe:/a:s9y:serendipity:0.7_beta2
cpe:/a:s9y:serendipity:0.6_rc1
cpe:/a:s9y:serendipity:0.5_pl1
cpe:/a:s9y:serendipity:0.4S9Y Serendipity 0.4
cpe:/a:s9y:serendipity:0.6_rc2
cpe:/a:s9y:serendipity:0.6_pl1
cpe:/a:s9y:serendipity:0.5
cpe:/a:s9y:serendipity:0.7S9Y Serendipity 0.7
cpe:/a:s9y:serendipity:0.7_beta1
cpe:/a:s9y:serendipity:0.6_pl3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2525
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2525
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-876
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18322
(PATCH)  XF  serendipity-combatphp-xss(18322)
http://www.securityfocus.com/bid/11790
(PATCH)  BID  11790
http://www.osvdb.org/12177
(VENDOR_ADVISORY)  OSVDB  12177
http://securitytracker.com/id?1012383
(PATCH)  SECTRACK  1012383
http://secunia.com/advisories/13357
(VENDOR_ADVISORY)  SECUNIA  13357
http://sourceforge.net/tracker/index.php?func=detail&aid=1076762&group_id=75065&atid=542822
(UNKNOWN)  CONFIRM  http://sourceforge.net/tracker/index.php?func=detail&aid=1076762&group_id=75065&atid=542822

- 漏洞信息

S9Y Serendipity远程跨站脚本漏洞
中危 跨站脚本
2004-12-31 00:00:00 2007-07-20 00:00:00
远程  
        Serendipity 0.7.1之前版本的compat.php存在跨站脚本(XSS)漏洞。远程攻击者可以借助searchTerm变量注入任意web脚本。

- 公告与补丁

        The vendor has released an upgrade dealing with this issue.
        S9Y Serendipity 0.3
        
        S9Y Serendipity 0.4
        
        S9Y Serendipity 0.5
        
        S9Y Serendipity 0.5 -pl1
        
        S9Y Serendipity 0.6
        
        S9Y Serendipity 0.6 -rc1
        
        S9Y Serendipity 0.6 -pl3
        
        S9Y Serendipity 0.6 -rc2
        
        S9Y Serendipity 0.6 -pl2
        
        S9Y Serendipity 0.6 -pl1
        
        S9Y Serendipity 0.7 -rc1
        
        S9Y Serendipity 0.7 beta1
        
        S9Y Serendipity 0.7 beta3
        
        S9Y Serendipity 0.7
        
        S9Y Serendipity 0.7 -beta4
        
        S9Y Serendipity 0.7 -beta2
        

- 漏洞信息

12177
Serendipity compat.php searchTerm Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Serendipity contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'searchTerm' variables in the 'search' module. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-12-02 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.7.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站