CVE-2004-2497
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:18
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the error handler in Hitachi Web Page Generator and Web Page Generator Enterprise 4.01 and earlier, when using the default error template and debug mode is set to ON, allows remote attackers to inject arbitrary web script or HTML via unknown attack vectors.


[CNNVD]Hitachi Web Page Generator跨站脚本和信息泄露漏洞(CNNVD-200412-1140)

        Hitachi Web Page Generator和Web Page Generator Enterprise 4.01及其早期版本的错误处理程序存在跨站脚本(XSS)漏洞。当使用默认出错模板和调试方式设定为ON时,远程攻击者借助未知攻击向量注入任意web脚本或者HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:hitachi:web_page_generator_enterprise:03_03
cpe:/a:hitachi:web_page_generator_enterprise:03_02_c
cpe:/a:hitachi:web_page_generator_enterprise:04_01
cpe:/a:hitachi:web_page_generator_enterprise:04_00
cpe:/a:hitachi:web_page_generator:01_00
cpe:/a:hitachi:web_page_generator:02_00_c
cpe:/a:hitachi:web_page_generator_enterprise:03_00
cpe:/a:hitachi:web_page_generator_enterprise:03_03_d
cpe:/a:hitachi:web_page_generator_enterprise:03_03_c
cpe:/a:hitachi:web_page_generator:01_01_c
cpe:/a:hitachi:web_page_generator_enterprise:04_00_c
cpe:/a:hitachi:web_page_generator:02_00
cpe:/a:hitachi:web_page_generator_enterprise:04_01_b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2497
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2497
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1140
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16822
(UNKNOWN)  XF  web-page-generator-xss(16822)
http://www.securityfocus.com/bid/10818
(UNKNOWN)  BID  10818
http://www.osvdb.org/8264
(UNKNOWN)  OSVDB  8264
http://www.hitachi-support.com/security_e/vuls_e/HS04-003_e/index-e.html
(VENDOR_ADVISORY)  CONFIRM  http://www.hitachi-support.com/security_e/vuls_e/HS04-003_e/index-e.html
http://secunia.com/advisories/12150
(VENDOR_ADVISORY)  SECUNIA  12150

- 漏洞信息

Hitachi Web Page Generator跨站脚本和信息泄露漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-11-11 00:00:00
远程  
        Hitachi Web Page Generator和Web Page Generator Enterprise 4.01及其早期版本的错误处理程序存在跨站脚本(XSS)漏洞。当使用默认出错模板和调试方式设定为ON时,远程攻击者借助未知攻击向量注入任意web脚本或者HTML。

- 公告与补丁

        The vendor has released a security advisory addressing these issues. Please see the referenced advisory for further information.

- 漏洞信息

8264
Hitachi Web Page Generator Error Page XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Hitachi Web Page Generator contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate input upon submission to the error handling scripts. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-07-28 Unknow
2004-07-28 Unknow

- 解决方案

Upgrade to versions 03-03-/D or 04-02-/L or higher, as they have been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站