发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:18

[原文]Cross-site scripting (XSS) vulnerability in _error in Ability Mail Server 1.18 allows remote attackers to inject arbitrary web script or HTML via the erromsg parameter.

[CNNVD]Code-Crafters Ability邮件服务器 多个漏洞。(CNNVD-200412-570)


- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  ability-errormsg-xss(16676)
(UNKNOWN)  BID  10695

- 漏洞信息

Code-Crafters Ability邮件服务器 多个漏洞。
中危 跨站脚本
2004-12-31 00:00:00 2005-11-11 00:00:00

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: .

- 漏洞信息 (24268)

Code-Crafters Ability Mail Server 1.18 errormsg Parameter XSS (EDBID:24268)
multiple remote
2004-07-12 Verified
0 dr_insane
N/A [点击下载]

Ability Mail Server is reported prone to multiple vulnerabilities that may allow a remote attacker to carry out cross-site scripting and denial of service attacks.

The server is prone to a cross-site scripting vulnerability that may allow an attacker to execute arbitrary HTML and script code in the browser of a vulnerable user.

It is reported that the mail server is also prone to a denial of service vulnerability. This issue presents itself when an attacker establishes about 150-200 connections to various services such as SMTP, POP3, View FeaturesIMAP4, WebMail etc.

These issue are reported to affect Ability Mail Server version 1.18, however, other versions may be affected as well.[id]&errormsg=<script>alert(document.cookie)</script>		

- 漏洞信息

Ability Mail Server errormsg Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Ability Mail Server contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'errormsg' parameter upon submission to the '_error' page. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-07-11 Unknow
2004-07-11 Unknow

- 解决方案

Upgrade to version 2.10 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者