CVE-2004-2478
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2011-05-06 00:00:00
NMCO    

[原文]Unspecified vulnerability in Jetty HTTP Server, as used in (1) IBM Trading Partner Interchange before 4.2.4, (2) CA Unicenter Web Services Distributed Management (WSDM) before 3.11, and possibly other products, allows remote attackers to read arbitrary files via a .. (dot dot) in the URL.


[CNNVD]Jetty目录遍历漏洞(CNNVD-200412-806)

        Jetty HTTP Server用在(1)IBM Trading Partner Interchange 4.2.4之前的版本,(2)CA Unicenter Web Services Distributed Management (WSDM) 3.11之前的版本,以及可能还包括其他产品时存在未明漏洞,远程攻击者可以借助一个URL中的..(点 点)读取任意文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:jetty:jetty_http_server:3.1.7
cpe:/a:jetty:jetty_http_server:4.2.15
cpe:/a:jetty:jetty_http_server:4.2.5
cpe:/a:jetty:jetty_http_server:4.2.4
cpe:/a:jetty:jetty_http_server:4.2.9
cpe:/a:ibm:trading_partner_interchange:4.2.1IBM Trading Partner Interchange 4.2.1
cpe:/a:jetty:jetty_http_server:4.2.11
cpe:/a:jetty:jetty_http_server:4.2.7
cpe:/a:jetty:jetty_http_server:4.1.0
cpe:/a:jetty:jetty_http_server:4.2.16
cpe:/a:jetty:jetty_http_server:3.1.6
cpe:/a:jetty:jetty_http_server:4.2.6
cpe:/a:jetty:jetty_http_server:4.2.19
cpe:/a:jetty:jetty_http_server:4.2.18
cpe:/a:ibm:trading_partner_interchange:4.2.2IBM Trading Partner Interchange 4.2.2
cpe:/a:jetty:jetty_http_server:4.1.0_rc4
cpe:/a:jetty:jetty_http_server:4.1.1
cpe:/a:ca:unicenter_web_services_distributed_management:3.1
cpe:/a:jetty:jetty_http_server:4.2.12
cpe:/a:jetty:jetty_http_server:4.2.14
cpe:/a:jetty:jetty_http_server:4.2.17

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2478
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2478
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-806
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17600
(UNKNOWN)  XF  trading-partner-gain-access(17600)
http://www.vupen.com/english/advisories/2006/3873
(VENDOR_ADVISORY)  VUPEN  ADV-2006-3873
http://www.securityfocus.com/bid/11330
(UNKNOWN)  BID  11330
http://www.securityfocus.com/archive/1/archive/1/447648/100/0/threaded
(UNKNOWN)  BUGTRAQ  20061003 [CAID 34661]: CA Unicenter WSDM File System Read Access Vulnerability
http://www.osvdb.org/10490
(UNKNOWN)  OSVDB  10490
http://www-1.ibm.com/support/docview.wss?uid=swg21178665
(VENDOR_ADVISORY)  MISC  http://www-1.ibm.com/support/docview.wss?uid=swg21178665
http://securitytracker.com/id?1016975
(UNKNOWN)  SECTRACK  1016975
http://securitytracker.com/id?1011545
(UNKNOWN)  SECTRACK  1011545
http://secunia.com/advisories/22229
(VENDOR_ADVISORY)  SECUNIA  22229
http://secunia.com/advisories/12703
(VENDOR_ADVISORY)  SECUNIA  12703
http://lists.grok.org.uk/pipermail/full-disclosure/2006-October/049846.html
(UNKNOWN)  FULLDISC  20061003 [CAID 34661]: CA Unicenter WSDM File System Read Access Vulnerability

- 漏洞信息

Jetty目录遍历漏洞
高危 输入验证
2004-12-31 00:00:00 2006-10-16 00:00:00
远程  
        Jetty HTTP Server用在(1)IBM Trading Partner Interchange 4.2.4之前的版本,(2)CA Unicenter Web Services Distributed Management (WSDM) 3.11之前的版本,以及可能还包括其他产品时存在未明漏洞,远程攻击者可以借助一个URL中的..(点 点)读取任意文件。

- 公告与补丁

        Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.
        Please see the references for more information.

- 漏洞信息

10490
IBM Trading Partner Interchange Jetty Server Traversal Arbitrary File Access
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Public

- 漏洞描述

Trading Partner Interchange contains a flaw that may allow a malicious user to arbitarily access files. The issue is triggered when a specially crafted URL is submitted to the Jetty HTTP server. It is possible that the flaw may allow arbitrary file access resulting in a loss of confidentiality.

- 时间线

2004-10-05 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.2.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站