CVE-2004-2461
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:12
NMCO    

[原文]Buffer overflow in pop3.c in gnubiff before 2.0.0 allows attackers to cause a denial of service (crash) and possibly execute arbitrary code.


[CNNVD]gnubiff多个远程POP3协议漏洞(CNNVD-200412-413)

        gnubiff 2.0.0之前版本中的pop3.c存在缓冲区溢出漏洞。攻击者可以导致服务拒绝(崩溃)并且可能执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gnu:gnubiff:1.4.0GNU gnubiff 1.4.0
cpe:/a:gnu:gnubiff:1.2.0GNU gnubiff 1.2.0
cpe:/a:gnu:gnubiff:1.0.6GNU gnubiff 1.0.6
cpe:/a:gnu:gnubiff:1.0.7GNU gnubiff 1.0.7
cpe:/a:gnu:gnubiff:1.0.3GNU gnubiff 1.0.3
cpe:/a:gnu:gnubiff:1.0.4GNU gnubiff 1.0.4
cpe:/a:gnu:gnubiff:1.0.8GNU gnubiff 1.0.8
cpe:/a:gnu:gnubiff:1.0.5GNU gnubiff 1.0.5
cpe:/a:gnu:gnubiff:1.0.10GNU gnubiff 1.0.10
cpe:/a:gnu:gnubiff:1.0.9GNU gnubiff 1.0.9

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2461
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2461
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-413
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17282
(PATCH)  XF  gnubiff-pop3-dos(17282)
http://www.securityfocus.com/bid/11123
(PATCH)  BID  11123
http://secunia.com/advisories/12445
(VENDOR_ADVISORY)  SECUNIA  12445
http://www.osvdb.org/9731
(UNKNOWN)  OSVDB  9731
http://gnubiff.sourceforge.net/changelog.php
(UNKNOWN)  CONFIRM  http://gnubiff.sourceforge.net/changelog.php

- 漏洞信息

gnubiff多个远程POP3协议漏洞
高危 缓冲区溢出
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        gnubiff 2.0.0之前版本中的pop3.c存在缓冲区溢出漏洞。攻击者可以导致服务拒绝(崩溃)并且可能执行任意代码。

- 公告与补丁

        The vendor has released an upgrade dealing with this issue.
        GNU gnubiff 1.0.1
        
        GNU gnubiff 1.0.10
        
        GNU gnubiff 1.0.2
        
        GNU gnubiff 1.0.3
        
        GNU gnubiff 1.0.4
        
        GNU gnubiff 1.0.5
        
        GNU gnubiff 1.0.6
        
        GNU gnubiff 1.0.7
        
        GNU gnubiff 1.0.8
        
        GNU gnubiff 1.0.9
        
        GNU gnubiff 1.2
        
        GNU gnubiff 1.4
        

- 漏洞信息

9730
gnubiff POP3 Unspecified Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

gnubiff contains a flaw related to the 'pop3.c' file that may allow a remote attacker to cause a buffer overflow. No further details have been provided.

- 时间线

2004-09-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站