CVE-2004-2456
CVSS7.5
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:11
NMCOE    

[原文]SQL injection vulnerability in index.php in miniBB 1.7f and earlier allows remote attackers to execute arbitrary SQL commands via the user parameter in a userinfo action.


[CNNVD]MiniBB远程SQL注入漏洞(CNNVD-200412-850)

        miniBB 1.7f及其早期版本的index.php存在SQL注入漏洞。远程攻击者可以借助用户信息行为的用户参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:minibb:minibb:1.7c
cpe:/a:minibb:minibb:1.6
cpe:/a:minibb:minibb:1.7
cpe:/a:minibb:minibb:1.2
cpe:/a:minibb:minibb:1.7a
cpe:/a:minibb:minibb:1.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2456
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2456
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-850
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/18080
(PATCH)  XF  minibb-user-sql-injection(18080)
http://www.securityfocus.com/bid/11688
(PATCH)  BID  11688
http://www.osvdb.org/11711
(PATCH)  OSVDB  11711
http://securitytracker.com/id?1012164
(PATCH)  SECTRACK  1012164
http://www.minibb.net/forums/index.php?action=vthread&forum=9&topic=1854
(VENDOR_ADVISORY)  CONFIRM  http://www.minibb.net/forums/index.php?action=vthread&forum=9&topic=1854
http://www.minibb.net/forums/index.php?action=vthread&forum=1&topic=1767
(UNKNOWN)  MISC  http://www.minibb.net/forums/index.php?action=vthread&forum=1&topic=1767

- 漏洞信息

MiniBB远程SQL注入漏洞
高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        miniBB 1.7f及其早期版本的index.php存在SQL注入漏洞。远程攻击者可以借助用户信息行为的用户参数执行任意SQL命令。

- 公告与补丁

        The vendor has released miniBB 1.7f to address this issue.
        MiniBB MiniBB 1.2
        
        MiniBB MiniBB 1.5
        
        MiniBB MiniBB 1.6
        
        MiniBB MiniBB 1.7 c
        
        MiniBB MiniBB 1.7
        
        MiniBB MiniBB 1.7 a
        

- 漏洞信息 (635)

miniBB Input Validation Hole in 'user' Parameter (EDBID:635)
php webapps
2004-11-16 Verified
0 n/a
N/A [点击下载]
Example:

 http://[target]/minibb/index.php?action=userinfo&user=1%20union%20select%201,2,user_password%20from%20minibb_users/* 

# milw0rm.com [2004-11-16]
		

- 漏洞信息

11711
miniBB index.php user Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

miniBB contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the 'user' variable submitted to bb_func_usernfo.php via the index.php script is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-10-27 Unknow
2004-10-27 Unknow

- 解决方案

Upgrade to version 1.7f or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站