CVE-2004-2408
CVSS3.6
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:44:03
NMCO    

[原文]Linux VServer 1.27 and earlier, 1.3.9 and earlier, and 1.9.1 and earlier shares /proc permissions across all virtual and host servers, which allows local users with the ability to set permissions in /proc to obtain system information or cause a denial of service on other virtual servers or the host server.


[CNNVD]Linux VServer Project ProcFS弱共享权限漏洞(CNNVD-200412-624)

        
        Linux VServer是一个允许用户在一个普通的Linux服务器上建立虚拟专用的服务器的软件。
        Linux VServer不正确设置procfs挂接目录(procfs mounted directory),本地攻击者可以利用这个漏洞获得敏感内存内容或对主机系统进行拒绝服务攻击。
        VSserver中的用户可以更改/proc的权限,如访问权限和属主。利用这个问题,攻击者可以设置权限防止其他用户读取/procfs目录信息而造成一定范围的拒绝服务,或者访问其他Vserver上的进程敏感信息或其他数据。
        

- CVSS (基础分值)

CVSS分值: 3.6 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:vserver:linux-vserver:1.3.9
cpe:/a:vserver:linux-vserver:1.26
cpe:/a:vserver:linux-vserver:1.3.4
cpe:/a:vserver:linux-vserver:1.3.8
cpe:/a:vserver:linux-vserver:1.27
cpe:/a:vserver:linux-vserver:1.3.6
cpe:/a:vserver:linux-vserver:1.22
cpe:/a:vserver:linux-vserver:1.21
cpe:/a:vserver:linux-vserver:1.3.3
cpe:/a:vserver:linux-vserver:1.3.7
cpe:/a:vserver:linux-vserver:1.3.1
cpe:/a:vserver:linux-vserver:1.3.2
cpe:/a:vserver:linux-vserver:1.3.5
cpe:/a:vserver:linux-vserver:1.9.1
cpe:/a:vserver:linux-vserver:1.3.0
cpe:/a:vserver:linux-vserver:1.20
cpe:/a:vserver:linux-vserver:1.23
cpe:/a:vserver:linux-vserver:1.24
cpe:/a:vserver:linux-vserver:1.25

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2408
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2408
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-624
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16626
(PATCH)  XF  linux-vserver-modify-permissions(16626)
http://www.securityfocus.com/bid/10660
(PATCH)  BID  10660
http://secunia.com/advisories/12021
(VENDOR_ADVISORY)  SECUNIA  12021
http://www.osvdb.org/7480
(UNKNOWN)  OSVDB  7480
http://securitytracker.com/id?1010643
(VENDOR_ADVISORY)  SECTRACK  1010643
http://linux-vserver.org/ChangeLog
(UNKNOWN)  MISC  http://linux-vserver.org/ChangeLog
http://archives.neohapsis.com/archives/bugtraq/2004-07/0040.html
(VENDOR_ADVISORY)  BUGTRAQ  20040703 Linux Virtual Server/Secure Context procfs shared permissions flaw

- 漏洞信息

Linux VServer Project ProcFS弱共享权限漏洞
低危 访问验证错误
2004-12-31 00:00:00 2005-10-20 00:00:00
本地  
        
        Linux VServer是一个允许用户在一个普通的Linux服务器上建立虚拟专用的服务器的软件。
        Linux VServer不正确设置procfs挂接目录(procfs mounted directory),本地攻击者可以利用这个漏洞获得敏感内存内容或对主机系统进行拒绝服务攻击。
        VSserver中的用户可以更改/proc的权限,如访问权限和属主。利用这个问题,攻击者可以设置权限防止其他用户读取/procfs目录信息而造成一定范围的拒绝服务,或者访问其他Vserver上的进程敏感信息或其他数据。
        

- 公告与补丁

        临时解决方法:
        如果您不能立刻安装补丁或者升级,CNNVD建议您采取以下措施以降低威胁:
        * 以超级用户权限在主机系统中进行如下设置:
        mount -o remount,ro /proc
        厂商补丁:
        VServer
        -------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        VServer Upgrade Linux-VServer Stable Release 1.28
        
        http://www.13thfloor.at/vserver/s_release/v1.28/

- 漏洞信息

7480
VServer procfs Arbitrary Server Information Disclosure
Local Access Required Information Disclosure
Loss of Confidentiality

- 漏洞描述

Linux-VServer contains a flaw that may lead to an unauthorized information disclosure. The issue is caused by weak permissions on the proc file system, which may allow the disclosure of virtual server or system information by local users resulting in a loss of confidentiality.

- 时间线

2004-07-04 2004-06-30
2004-07-04 Unknow

- 解决方案

Upgrade to version 1.28 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站