CVE-2004-2381
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:58
NMCO    

[原文]HttpRequest.java in Jetty HTTP Server before 4.2.19 allows remote attackers to cause denial of service (memory usage and application crash) via HTTP requests with a large Content-Length.


[CNNVD]Jetty未明的服务拒绝漏洞(CNNVD-200412-728)

        Jetty HTTP Server 4.2.19以前版本的HttpRequest.java存在漏洞。远程攻击者借助具有超长Content-Length的HTTP请求导致服务拒绝(内存的使用情况和应用程序崩溃)。
        

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:jetty:jetty_http_server:4.1.b1
cpe:/a:jetty:jetty_http_server:4.0.d0
cpe:/a:jetty:jetty_http_server:4.2.10
cpe:/a:jetty:jetty_http_server:4.2.9_rc1
cpe:/a:jetty:jetty_http_server:4.0.d3
cpe:/a:jetty:jetty_http_server:4.2.14_rc1
cpe:/a:jetty:jetty_http_server:4.0.b2
cpe:/a:jetty:jetty_http_server:4.2.2
cpe:/a:jetty:jetty_http_server:4.1.0
cpe:/a:jetty:jetty_http_server:4.2.0_beta0
cpe:/a:jetty:jetty_http_server:4.1.0_rc5
cpe:/a:jetty:jetty_http_server:4.1.1
cpe:/a:jetty:jetty_http_server:4.2.10_pre0
cpe:/a:jetty:jetty_http_server:4.1.d2
cpe:/a:jetty:jetty_http_server:4.0.5
cpe:/a:jetty:jetty_http_server:4.2.3
cpe:/a:jetty:jetty_http_server:4.0_rc2
cpe:/a:jetty:jetty_http_server:4.0_rc1
cpe:/a:jetty:jetty_http_server:4.0.d1
cpe:/a:jetty:jetty_http_server:4.2.4
cpe:/a:jetty:jetty_http_server:4.2.11
cpe:/a:jetty:jetty_http_server:4.0.1_rc1
cpe:/a:jetty:jetty_http_server:4.0.d4
cpe:/a:jetty:jetty_http_server:4.2.1
cpe:/a:jetty:jetty_http_server:4.1.b0
cpe:/a:jetty:jetty_http_server:4.2.6
cpe:/a:jetty:jetty_http_server:4.2.14_rc0
cpe:/a:jetty:jetty_http_server:4.1.0_rc6
cpe:/a:jetty:jetty_http_server:4.0.b1
cpe:/a:jetty:jetty_http_server:4.2.0_rc1
cpe:/a:jetty:jetty_http_server:4.1.2
cpe:/a:jetty:jetty_http_server:4.2.12
cpe:/a:jetty:jetty_http_server:4.1.0_rc2
cpe:/a:jetty:jetty_http_server:4.1.4
cpe:/a:jetty:jetty_http_server:4.0_rc3
cpe:/a:jetty:jetty_http_server:4.1.3
cpe:/a:jetty:jetty_http_server:4.2.4_rc0
cpe:/a:jetty:jetty_http_server:4.2.5
cpe:/a:jetty:jetty_http_server:4.0.2
cpe:/a:jetty:jetty_http_server:4.2.9
cpe:/a:jetty:jetty_http_server:4.2.7
cpe:/a:jetty:jetty_http_server:4.2.0_rc0
cpe:/a:jetty:jetty_http_server:4.0.6
cpe:/a:jetty:jetty_http_server:4.2.0
cpe:/a:jetty:jetty_http_server:4.1.d1
cpe:/a:jetty:jetty_http_server:4.2.9_rc2
cpe:/a:jetty:jetty_http_server:4.1.d0
cpe:/a:jetty:jetty_http_server:4.0.1_rc2
cpe:/a:jetty:jetty_http_server:4.1.0_rc0
cpe:/a:jetty:jetty_http_server:4.0.b0
cpe:/a:jetty:jetty_http_server:4.2.17
cpe:/a:jetty:jetty_http_server:4.2.15
cpe:/a:jetty:jetty_http_server:4.0.1
cpe:/a:jetty:jetty_http_server:4.2.10_pre1
cpe:/a:jetty:jetty_http_server:4.0.d2
cpe:/a:jetty:jetty_http_server:4.1.0_rc3
cpe:/a:jetty:jetty_http_server:4.0.1_rc0
cpe:/a:jetty:jetty_http_server:4.0.4
cpe:/a:jetty:jetty_http_server:4.2.16
cpe:/a:jetty:jetty_http_server:4.2.18
cpe:/a:jetty:jetty_http_server:4.1.0_rc1
cpe:/a:jetty:jetty_http_server:4.2.15_rc0
cpe:/a:jetty:jetty_http_server:4.0.3
cpe:/a:jetty:jetty_http_server:4.2.8_01
cpe:/a:jetty:jetty_http_server:4.1.0_rc4
cpe:/a:jetty:jetty_http_server:4.0.0
cpe:/a:jetty:jetty_http_server:4.2.14

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2381
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2381
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-728
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=224743
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=224743
http://secunia.com/advisories/11166/
(VENDOR_ADVISORY)  SECUNIA  11166
http://xforce.iss.net/xforce/xfdb/15537
(UNKNOWN)  XF  jetty-dos(15537)
http://www.securityfocus.com/bid/9917
(UNKNOWN)  BID  9917
http://www.osvdb.org/4387
(UNKNOWN)  OSVDB  4387
http://cvs.sourceforge.net/viewcvs.py/jetty/Jetty/src/org/mortbay/http/HttpRequest.java?r1=1.75&r2=1.76
(UNKNOWN)  CONFIRM  http://cvs.sourceforge.net/viewcvs.py/jetty/Jetty/src/org/mortbay/http/HttpRequest.java?r1=1.75&r2=1.76

- 漏洞信息

Jetty未明的服务拒绝漏洞
中危 未知
2004-12-31 00:00:00 2006-08-31 00:00:00
远程  
        Jetty HTTP Server 4.2.19以前版本的HttpRequest.java存在漏洞。远程攻击者借助具有超长Content-Length的HTTP请求导致服务拒绝(内存的使用情况和应用程序崩溃)。
        

- 公告与补丁

        This issue has been addressed in Jetty 4.2.19.
        Jetty Jetty 4.1 .0RC4
        
        Jetty Jetty 4.1 .0
        
        Jetty Jetty 4.1.1
        
        Jetty Jetty 4.2.11
        
        Jetty Jetty 4.2.12
        
        Jetty Jetty 4.2.14
        
        Jetty Jetty 4.2.15
        
        Jetty Jetty 4.2.16
        
        Jetty Jetty 4.2.17
        
        Jetty Jetty 4.2.18
        
        Jetty Jetty 4.2.4
        
        Jetty Jetty 4.2.5
        
        Jetty Jetty 4.2.6
        
        Jetty Jetty 4.2.7
        
        Jetty Jetty 4.2.9
        

- 漏洞信息

4387
Jetty HTTP Server HttpRequest.java Content-Length Handling Remote Overflow DoS
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability Upgrade
Exploit Unknown Vendor Verified

- 漏洞描述

Jetty contains a flaw that may allow a malicious user to create a denial of service. The cause of this issue is currently unknown. It is possible that the flaw may result in a loss of availability.

- 时间线

2004-03-19 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.2.19 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站