CVE-2004-2364
CVSS5.0
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:55
NMCOE    

[原文]Cross-site request forgery (CSRF) vulnerability in PHPX 3.0 through 3.2.6 allows remote attackers to execute arbitrary commands via URLs that are automatically executed on behalf of the administrator, as demonstrated using (1) admin/page.php, (2) admin/news.php, (3) admin/user.php, (4) admin/images.php, (5) admin/page.php, or (6) admin/forums.php.


[CNNVD]PHPX多个管理员命令执行漏洞(CNNVD-200412-234)

        PHPX 3.0版本到3.2.6版本存在跨站请求伪造(CSRF)漏洞。远程攻击者可以借助自动代表管理员执行的URLs来执行任意命令,正如使用(1)admin/page.php,(2)admin/news.php,(3)admin/user.php,(4)admin/images.php,(5)admin/page.php或(6)admin/forums.php。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpx:phpx:3.2.3
cpe:/a:phpx:phpx:3.0.0
cpe:/a:phpx:phpx:3.2.0
cpe:/a:phpx:phpx:3.2.4
cpe:/a:phpx:phpx:3.2.5
cpe:/a:phpx:phpx:3.1.2
cpe:/a:phpx:phpx:3.2.2
cpe:/a:phpx:phpx:3.1.4
cpe:/a:phpx:phpx:3.1.0
cpe:/a:phpx:phpx:3.0.1
cpe:/a:phpx:phpx:3.0.4
cpe:/a:phpx:phpx:3.0.3
cpe:/a:phpx:phpx:3.1.1
cpe:/a:phpx:phpx:3.0.7
cpe:/a:phpx:phpx:3.0.6
cpe:/a:phpx:phpx:3.2.1
cpe:/a:phpx:phpx:3.1.3
cpe:/a:phpx:phpx:3.2.6
cpe:/a:phpx:phpx:3.0.2
cpe:/a:phpx:phpx:3.0.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2364
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2364
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-234
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/10284
(PATCH)  BID  10284
http://www.phpx.org/project.php?action=view&project_id=1
(PATCH)  MISC  http://www.phpx.org/project.php?action=view&project_id=1
http://www.securityfocus.com/archive/1/362230
(VENDOR_ADVISORY)  BUGTRAQ  20040504 Vulnerabilities In PHPX 3.26 And Earlier
http://www.osvdb.org/5911
(UNKNOWN)  OSVDB  5911
http://www.osvdb.org/5910
(UNKNOWN)  OSVDB  5910
http://www.osvdb.org/5909
(UNKNOWN)  OSVDB  5909
http://www.osvdb.org/5908
(UNKNOWN)  OSVDB  5908
http://www.osvdb.org/5907
(UNKNOWN)  OSVDB  5907
http://securitytracker.com/id?1010061
(UNKNOWN)  SECTRACK  1010061
http://secunia.com/advisories/11554
(UNKNOWN)  SECUNIA  11554

- 漏洞信息

PHPX多个管理员命令执行漏洞
中危 访问验证错误
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        PHPX 3.0版本到3.2.6版本存在跨站请求伪造(CSRF)漏洞。远程攻击者可以借助自动代表管理员执行的URLs来执行任意命令,正如使用(1)admin/page.php,(2)admin/news.php,(3)admin/user.php,(4)admin/images.php,(5)admin/page.php或(6)admin/forums.php。

- 公告与补丁

        The vendor has released an upgrade that deals with these and other issues.
        PHPX PHPX 3.0
        
        PHPX PHPX 3.0.1
        
        PHPX PHPX 3.0.2
        
        PHPX PHPX 3.0.3
        
        PHPX PHPX 3.0.4
        
        PHPX PHPX 3.0.5
        
        PHPX PHPX 3.0.6
        
        PHPX PHPX 3.0.7
        
        PHPX PHPX 3.1 .0
        
        PHPX PHPX 3.1.1
        
        PHPX PHPX 3.1.2
        
        PHPX PHPX 3.1.3
        
        PHPX PHPX 3.1.4
        
        PHPX PHPX 3.2 .0
        
        PHPX PHPX 3.2.1
        
        PHPX PHPX 3.2.2
        
        PHPX PHPX 3.2.3
        
        PHPX PHPX 3.2.4
        
        PHPX PHPX 3.2.5
        
        PHPX PHPX 3.2.6
        

- 漏洞信息 (24088)

PHPX 3.x admin/page.php CSRF Arbitrary Command Execution (EDBID:24088)
php webapps
2004-05-05 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/10284/info

It has been reported that PHPX is affected by multiple administrator command execution vulnerabilities. These issues are due to a failure of the application to properly validate access to administrative commands.

This issue could permit a remote attacker to create a malicious URI link or embed a malicious URI between bbCode image tags, which includes hostile HTML and script code. If an unsuspecting forum administrator activated this URI, the attacker-supplied command would be carried out with the administrator's privileges. This would occur in the security context of the affected web site and would cause various administrator actions to be taken.

http://www.example.com/admin/page.php?action=delete&page_id=[VID]		

- 漏洞信息 (24089)

PHPX 3.x admin/news.php CSRF Arbitrary Command Execution (EDBID:24089)
php webapps
2004-05-05 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/10284/info
 
It has been reported that PHPX is affected by multiple administrator command execution vulnerabilities. These issues are due to a failure of the application to properly validate access to administrative commands.
 
This issue could permit a remote attacker to create a malicious URI link or embed a malicious URI between bbCode image tags, which includes hostile HTML and script code. If an unsuspecting forum administrator activated this URI, the attacker-supplied command would be carried out with the administrator's privileges. This would occur in the security context of the affected web site and would cause various administrator actions to be taken.

http://www.example.com/admin/news.php?action=delete&news_id=[VID]		

- 漏洞信息 (24090)

PHPX 3.x admin/user.php CSRF Arbitrary Command Execution (EDBID:24090)
php webapps
2004-05-05 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/10284/info
  
It has been reported that PHPX is affected by multiple administrator command execution vulnerabilities. These issues are due to a failure of the application to properly validate access to administrative commands.
  
This issue could permit a remote attacker to create a malicious URI link or embed a malicious URI between bbCode image tags, which includes hostile HTML and script code. If an unsuspecting forum administrator activated this URI, the attacker-supplied command would be carried out with the administrator's privileges. This would occur in the security context of the affected web site and would cause various administrator actions to be taken.

http://www.example.com/admin/user.php?action=delete&user_id=[VID]		

- 漏洞信息 (24091)

PHPX 3.x admin/images.php CSRF Arbitrary Command Execution (EDBID:24091)
php webapps
2004-05-05 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/10284/info
  
It has been reported that PHPX is affected by multiple administrator command execution vulnerabilities. These issues are due to a failure of the application to properly validate access to administrative commands.
  
This issue could permit a remote attacker to create a malicious URI link or embed a malicious URI between bbCode image tags, which includes hostile HTML and script code. If an unsuspecting forum administrator activated this URI, the attacker-supplied command would be carried out with the administrator's privileges. This would occur in the security context of the affected web site and would cause various administrator actions to be taken.

http://www.example.com/admin/images.php?action=delete&image_id=[VID]		

- 漏洞信息 (24092)

PHPX 3.x admin/forums.php CSRF Arbitrary Command Execution (EDBID:24092)
php webapps
2004-05-05 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/10284/info
  
It has been reported that PHPX is affected by multiple administrator command execution vulnerabilities. These issues are due to a failure of the application to properly validate access to administrative commands.
  
This issue could permit a remote attacker to create a malicious URI link or embed a malicious URI between bbCode image tags, which includes hostile HTML and script code. If an unsuspecting forum administrator activated this URI, the attacker-supplied command would be carried out with the administrator's privileges. This would occur in the security context of the affected web site and would cause various administrator actions to be taken.

http://www.example.com/admin/forums.php?action=words&subaction=delete&word_id=[VID]
http://www.example.com/admin/forums.php?action=flag&subaction=delete&flag_id=[VID]
http://www.example.com/admin/forums.php?action=xcode&subaction=delete&xcode_id=[VID]		

- 漏洞信息

5907
PHPX admin/page.php CSRF Arbitrary Command Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PHPX contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to the /admin/page.php script not properly sanitizing arguments or validating user identity. With a specially crafted URL, an attacker can potentially execute custom commands by posting it to a message forum that will be read by the administrator. Upon reading the message, the malicious URL will be processed and executed with administrative privileges.

- 时间线

2004-05-04 Unknow
2004-05-04 Unknow

- 解决方案

Upgrade to version 3.3.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站