CVE-2004-2363
CVSS4.3
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:55
NMCOE    

[原文]Validate-Before-Canonicalize vulnerability in the checkURI function in functions.inc.php in PHPX 3.0 through 3.2.6 allows remote attackers to conduct cross-site scripting (XSS) attacks via hex-encoded tags, which bypass the check for literal "<", ">", "(", and ")" characters, as demonstrated using the limit parameter to forums.php and a variety of other vectors.


[CNNVD]PHPX多个跨站脚本攻击(XSS)漏洞(CNNVD-200412-776)

        PHPX 3.0到3.2.6版本的functions.inc.php中的checkURI函数存在规范化前认证漏洞。远程攻击者可以借助十六进制编码标签导致跨站脚本攻击(XSS),该漏洞绕过对文字字符“<”,“>”,“(”和“)”的检查,正如使用到forums.php的limit参数以及其他多种向量。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpx:phpx:3.2.3
cpe:/a:phpx:phpx:3.0.0
cpe:/a:phpx:phpx:3.2.0
cpe:/a:phpx:phpx:3.2.4
cpe:/a:phpx:phpx:3.2.5
cpe:/a:phpx:phpx:3.1.2
cpe:/a:phpx:phpx:3.2.2
cpe:/a:phpx:phpx:3.1.4
cpe:/a:phpx:phpx:3.1.0
cpe:/a:phpx:phpx:3.0.1
cpe:/a:phpx:phpx:3.0.4
cpe:/a:phpx:phpx:3.0.3
cpe:/a:phpx:phpx:3.1.1
cpe:/a:phpx:phpx:3.0.7
cpe:/a:phpx:phpx:3.0.6
cpe:/a:phpx:phpx:3.2.1
cpe:/a:phpx:phpx:3.1.3
cpe:/a:phpx:phpx:3.2.6
cpe:/a:phpx:phpx:3.0.2
cpe:/a:phpx:phpx:3.0.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2363
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2363
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-776
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/16065
(PATCH)  XF  phpx-xss(16065)
http://www.securityfocus.com/bid/10283
(PATCH)  BID  10283
http://www.phpx.org/project.php?action=view&project_id=1
(PATCH)  MISC  http://www.phpx.org/project.php?action=view&project_id=1
http://www.securityfocus.com/archive/1/362230
(VENDOR_ADVISORY)  BUGTRAQ  20040504 Vulnerabilities In PHPX 3.26 And Earlier

- 漏洞信息

PHPX多个跨站脚本攻击(XSS)漏洞
中危 跨站脚本
2004-12-31 00:00:00 2006-04-07 00:00:00
远程  
        PHPX 3.0到3.2.6版本的functions.inc.php中的checkURI函数存在规范化前认证漏洞。远程攻击者可以借助十六进制编码标签导致跨站脚本攻击(XSS),该漏洞绕过对文字字符“<”,“>”,“(”和“)”的检查,正如使用到forums.php的limit参数以及其他多种向量。

- 公告与补丁

        The vendor has released an upgrade that deals with these and other issues.
        PHPX PHPX 3.0
        
        PHPX PHPX 3.0.1
        
        PHPX PHPX 3.0.2
        
        PHPX PHPX 3.0.3
        
        PHPX PHPX 3.0.4
        
        PHPX PHPX 3.0.5
        
        PHPX PHPX 3.0.6
        
        PHPX PHPX 3.0.7
        
        PHPX PHPX 3.1 .0
        
        PHPX PHPX 3.1.1
        
        PHPX PHPX 3.1.2
        
        PHPX PHPX 3.1.3
        
        PHPX PHPX 3.1.4
        
        PHPX PHPX 3.2 .0
        
        PHPX PHPX 3.2.1
        
        PHPX PHPX 3.2.2
        
        PHPX PHPX 3.2.3
        
        PHPX PHPX 3.2.4
        
        PHPX PHPX 3.2.5
        
        PHPX PHPX 3.2.6
        

- 漏洞信息 (24083)

PHPX 3.x Multiple Cross-Site Scripting Vulnerabilities (EDBID:24083)
php webapps
2004-05-05 Verified
0 JeiAr
N/A [点击下载]
source: http://www.securityfocus.com/bid/10283/info

It has been reported that PHPX is affected by multiple cross-site scripting vulnerabilities. These issues are due to a failure of the application to properly sanitize user-supplied URI input.

These issues could permit a remote attacker to create a malicious URI link that includes hostile HTML and script code. If this link were followed, the hostile code may be rendered in the web browser of the victim user. This would occur in the security context of the affected web site and may allow for theft of cookie-based authentication credentials or other attacks.

http://www.example.com/forums.php?forum_id=[VID]&limit=25%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]&topic_id=[VID]&limit=15%3Ciframe%3E
http://www.example.com/users.php?action=&limit=100%3Ciframe%3E
http://www.example.com/users.php?action=view&user_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?action=post&forum_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?action=search&search_id=[VID]&limit=25%3E%3Ciframe%3E
http://www.example.com/users.php?action=email&user_id=%3E%3Ciframe%3E
http://www.example.com/users.php?action=view&user_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]&topic_id=[VID]&limit=%3E%3Ciframe%3E
http://www.example.com/forums.php?action=post&forum_id=[VID]&topic_id=[VID]%3E%3Ciframe%3E
http://www.example.com/news.php?news_id=[VID]%3E%3Ciframe%3E
http://www.example.com/forums.php?forum_id=[VID]&topic_id=[VID]%3E%3Ciframe%3E
		

- 漏洞信息

5903
PHPX forums.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PHPX contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate multiple variables upon submission to the "forums.php" script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2004-05-04 Unknow
2004-05-04 Unknow

- 解决方案

Upgrade to version 3.3.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站