CVE-2004-2354
CVSS6.8
发布时间 :2004-12-31 00:00:00
修订时间 :2008-09-05 16:43:54
NMCO    

[原文]SQL injection vulnerability in 4nGuestbook 0.92 for PHP-Nuke 6.5 through 6.9 allows remote attackers to modify SQL statements via the entry parameter to modules.php, which can also facilitate cross-site scripting (XSS) attacks when MySQL errors are triggered.


[CNNVD]PHP-Nuke 4nGuestbookSQL注入漏洞(CNNVD-200412-1038)

        PHP-Nuke 6.5和6.9版本的4nGuestbook 0.92存在SQL注入漏洞。远程攻击者借助modules.php模块的项参数修改SQL语句,该漏洞也可以在MySQL错误触发时促进跨站点脚本(XSS)攻击。

- CVSS (基础分值)

CVSS分值: 6.8 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:warpspeed:4nguestbook:0.92
cpe:/a:francisco_burzi:php-nuke:6.5_rc3
cpe:/a:francisco_burzi:php-nuke:6.5_beta1
cpe:/a:francisco_burzi:php-nuke:6.6
cpe:/a:francisco_burzi:php-nuke:6.9
cpe:/a:francisco_burzi:php-nuke:6.5_rc2
cpe:/a:francisco_burzi:php-nuke:6.5_final
cpe:/a:francisco_burzi:php-nuke:6.5_rc1
cpe:/a:francisco_burzi:php-nuke:6.5
cpe:/a:francisco_burzi:php-nuke:6.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2004-2354
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2004-2354
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200412-1038
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/15478
(UNKNOWN)  XF  4nguestbook-modules-xss(15478)
http://archives.neohapsis.com/archives/bugtraq/2004-03/0139.html
(VENDOR_ADVISORY)  BUGTRAQ  20040315 [waraxe-2004-SA#007 - XSS and SQL injection bugs in 4nguestbook module for PhpNuke]

- 漏洞信息

PHP-Nuke 4nGuestbookSQL注入漏洞
中危 跨站脚本
2004-12-31 00:00:00 2005-10-20 00:00:00
远程  
        PHP-Nuke 6.5和6.9版本的4nGuestbook 0.92存在SQL注入漏洞。远程攻击者借助modules.php模块的项参数修改SQL语句,该漏洞也可以在MySQL错误触发时促进跨站点脚本(XSS)攻击。

- 公告与补丁

        

- 漏洞信息

19865
4nGuestbook admin.php nbid Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

4nGuestBook contains a flaw that may allow a remote attacker to carry out an SQL injection attack. The issue is due to the 'admin.php' script not properly sanitizing user-supplied input to the 'nbid' variable. This may allow a remote attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2004-03-15 Unknow
2004-03-15 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站