发布时间 :2004-12-31 00:00:00
修订时间 :2017-07-10 21:31:47

[原文]SQL injection vulnerability in DotNetNuke (formerly IBuySpy Workshop) 1.0.6 through 1.0.10d allows remote attackers to modify the backend database via the (1) table and (2) field parameters in LinkClick.aspx.


        DotNetNuke(以前的IBuySpy Workshop)1.0.6到1.0.10d版本存在SQL注入漏洞。远程攻击者可以借助LinkClick.aspx中的(1)table参数,以及(2)field参数修改后端数据库。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:dotnetnuke:dotnetnuke:1.0.6DotNetNuke DotNetNuke 1.0.6
cpe:/a:dotnetnuke:dotnetnuke:1.0.8DotNetNuke DotNetNuke 1.0.8
cpe:/a:dotnetnuke:dotnetnuke:1.0.7DotNetNuke DotNetNuke 1.0.7
cpe:/a:dotnetnuke:dotnetnuke:1.0.9DotNetNuke DotNetNuke 1.0.9
cpe:/a:dotnetnuke:dotnetnuke:1.0.10dDotNetNuke DotNetNuke 1.0.10d

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  FULLDISC  20040128 Dotnetnuke Multiple Vulnerabilities
(PATCH)  BID  9518
(UNKNOWN)  XF  dotnetnuke-multiple-sql-injection(14973)

- 漏洞信息

高危 SQL注入
2004-12-31 00:00:00 2005-10-20 00:00:00
        DotNetNuke(以前的IBuySpy Workshop)1.0.6到1.0.10d版本存在SQL注入漏洞。远程攻击者可以借助LinkClick.aspx中的(1)table参数,以及(2)field参数修改后端数据库。

- 公告与补丁

        The vendor has released fixes to address this issue. Users are advised to download either DotNetNuke 1.0.10e - FULL (for those who are installing DotNetNuke for the first time or are running a version prior to 1.0.10d) or DotNetNuke 1.0.10e - PATCH (or those who are already running DotNetNuke 1.0.10d) from the vendor site.

- 漏洞信息

DotNetNuke LinkClick.aspx Multiple Field SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity, Loss of Availability

- 漏洞描述

DotNetNuke contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that "table" and "field" variable in the "LinkClick.aspx" module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2004-01-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.10e or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete